CompilerX64 Help

PowerBASIC-compatible command reference for CompilerX64. Each topic includes syntax, examples, current CompilerX64 status, and an assembly/code-generation section for CX64 technical work.

Command Index

  • #ASM / #ENDASM ACTIVE_BASELINE - Inline assembly block
  • #CINCLUDE / #CCODE ACTIVE_BASELINE - C language interop
  • #PCODE / #ENDP ACTIVE_BASELINE - PILOT code block
  • ACCEL ATTACH PLANNED - Attach keyboard accelerator table to dialog
  • ACCELERATOR PLANNED - Define keyboard accelerators (alternative)
  • ADDITEM PLANNED - Add item to listbox/combo/listview control
  • AND OPERATOR ACTIVE_BASELINE - Bitwise and logical operator
  • APPENDIX_A_LICENSE_AGREEMENT EXCLUDED_NONCOMPILER - License information
  • ARRAY ASSIGN ACTIVE_BASELINE - Assign array
  • ARRAY DELETE ACTIVE_BASELINE - Delete array element
  • ARRAY INSERT ACTIVE_BASELINE - Insert array element
  • ARRAY SCAN ACTIVE_BASELINE - Search array
  • ARRAY SORT ACTIVE_BASELINE - Sort array
  • ASC FUNCTION PLANNED - Return ASCII code for character
  • ASC STATEMENT PLANNED - Alternative syntax
  • ASSERT ACTIVE_BASELINE - Debug assertion statement
  • ASSIGN STATEMENT ACTIVE_BASELINE - Assign array values
  • ATN FUNCTION PLANNED - Arctangent calculation
  • BACKSPACE PLANNED - Keyboard escape sequence
  • BEEP ACTIVE_BASELINE - Console beep
  • C99 Language Adapter ACTIVE_BASELINE - C99 language pipeline adapter
  • CALL ACTIVE_BASELINE - Call subroutine/function (alternative)
  • CALLBACK ACTIVE_BASELINE - Define callback functions
  • CALLSTK PLANNED - Get stack information
  • CALLSTKCOUNT PLANNED - Count stack depth
  • CANCEL PLANNED - Dialog button identifier (%IDCANCEL)
  • CAPSLOCK PLANNED - Keyboard state check
  • CASE PLANNED - SELECT CASE clause
  • CB PLANNED - Callback function parameters (CB.CTL, CB.MSG, etc.)
  • CDWD FUNCTION PLANNED - Convert to double word
  • CHDIR STATEMENT PLANNED - Change current directory
  • CHDRIVE STATEMENT ACTIVE_BASELINE - Change disk drive
  • CHR$ FUNCTION PLANNED - Convert ASCII code to character
  • CIRCLE PLANNED - Draw circle/arc on graphics output
  • CLEAR PLANNED - Clear screen and variables
  • CLOSE ACTIVE_BASELINE - Close file handle
  • CLR PLANNED - Color reset statement
  • CLS ACTIVE_BASELINE - Clear screen/picture window
  • CLSID FUNCTION PLANNED - Get class identifier
  • CODEPTR FUNCTION PLANNED - Get code pointer/address
  • COLLECTION OBJECT PLANNED - Collection data structure
  • COLOR PLANNED - Set foreground/background colors
  • COM PLANNED - Communications port functions
  • COM OBJECTS PLANNED - Component Object Model support
  • COMM CLOSE PLANNED - Close communication port
  • COMM OPEN PLANNED - Open serial communications port
  • COMM PRINT PLANNED - Send data to communications device
  • COMM RECEIVE PLANNED - Receive data from communications device
  • COMM RESET PLANNED - Reset communication port
  • COMM SEND PLANNED - Send data (alternative)
  • COMM SET PLANNED - Configure communication parameters
  • COMM TIMEOUT PLANNED - Set receive timeout
  • COMMAND FUNCTION PLANNED - Get command line arguments
  • COMPARATIVE DATA TYPES C/C++ EXCLUDED_NONCOMPILER - Type comparisons with C/C++
  • COMPARE OPERATOR PLANNED - String comparison operator
  • COMPILE FUNCTIONS EXCLUDED_NONCOMPILER - Compiler directives and functions
  • COMPILE PREFERENCES EXCLUDED_NONCOMPILER - IDE compilation settings
  • CONST ACTIVE_BASELINE - Constant declaration
  • CONTROL ADD BUTTON PLANNED - Add command button control
  • CONTROL ADD CHECKBOX PLANNED - Add checkbox control
  • CONTROL ADD COMBOBOX PLANNED - Add combo box control
  • CONTROL ADD FRAME PLANNED - Add frame/groupbox control
  • CONTROL ADD GRAPHIC PLANNED - Add graphic/image control
  • CONTROL ADD HEADER PLANNED - Add header control
  • CONTROL ADD IMAGE PLANNED - Add image display control
  • CONTROL ADD IMGBUTTON PLANNED - Add button with image
  • CONTROL ADD LABEL PLANNED - Add static text label
  • CONTROL ADD LINE PLANNED - Add line drawing control
  • CONTROL ADD LISTBOX PLANNED - Add listbox control
  • CONTROL ADD LISTVIEW PLANNED - Add listview control
  • CONTROL ADD OPTION PLANNED - Add option/radio button
  • CONTROL ADD PROGRESSBAR PLANNED - Add progress bar control
  • CONTROL ADD SCROLLBAR PLANNED - Add scrollbar control
  • CONTROL ADD STATUSBAR PLANNED - Add status bar control
  • CONTROL ADD TAB PLANNED - Add tab control
  • CONTROL ADD TEXTBOX PLANNED - Add text input control
  • CONTROL ADD TOOLBAR PLANNED - Add toolbar control
  • CONTROL ADD TREEVIEW PLANNED - Add tree view control
  • CONTROL DISABLE PLANNED - Disable control
  • CONTROL ENABLE PLANNED - Enable control
  • CONTROL GET CHECK PLANNED - Get checkbox state
  • CONTROL GET CLIENT PLANNED - Get client area info
  • CONTROL GET FONT PLANNED - Get font information
  • CONTROL GET LOC PLANNED - Get position coordinates
  • CONTROL GET SIZE PLANNED - Get dimensions
  • CONTROL GET TEXT PLANNED - Get text content
  • CONTROL GET USER PLANNED - Get user data pointer
  • CONTROL HANDLE PLANNED - Get control window handle
  • CONTROL HIDE PLANNED - Hide control from view
  • CONTROL KILL PLANNED - Remove/destroy control
  • CONTROL NORMALIZE PLANNED - Normalize coordinates
  • CONTROL POST PLANNED - Post message to control
  • CONTROL REDRAW PLANNED - Force redraw of control
  • CONTROL SEND PLANNED - Send message to control
  • CONTROL SET CHECK PLANNED - Set checkbox state
  • CONTROL SET COLOR PLANNED - Set colors
  • CONTROL SET FOCUS PLANNED - Give keyboard focus
  • CONTROL SET FONT PLANNED - Change font
  • CONTROL SET IMAGE PLANNED - Set image display
  • CONTROL SET LOC PLANNED - Move control position
  • CONTROL SET OPTION PLANNED - Set option state
  • CONTROL SET SIZE PLANNED - Resize control
  • CONTROL SET TEXT PLANNED - Change text content
  • CONTROL SET USER PLANNED - Set user data pointer
  • CONTROL SHOW STATE PLANNED - Show/hide control
  • CONVERTING RC TO RES EXCLUDED_NONCOMPILER - Convert resource files
  • DATA COUNT FUNCTION ACTIVE_BASELINE - Count array elements
  • DATA STATEMENT ACTIVE_BASELINE - Define data section
  • DATACOUNT ACTIVE_BASELINE - Count DATA items
  • DATE SYSTEM VARIABLE PLANNED - Current date/time variable
  • DAYNAME$ FUNCTION PLANNED - Get day name string
  • DECLARE FUNCTION ACTIVE_BASELINE - Declare external Windows API function
  • DECLARE SUB ACTIVE_BASELINE - Declare external subroutine
  • DEFAULT VARIABLE TYPING PLANNED - Default type behavior
  • DEFINING CONSTANTS ACTIVE_BASELINE - Define named constants
  • DEFINING USER-DEFINED TYPES ACTIVE_BASELINE - Define custom types (TYPE)
  • DELAY ACTIVE_BASELINE - Pause program execution
  • DEPTH PLANNED - Stack depth information
  • DESCRIBE PLANNED - Describe object properties
  • DESKTOP GET CLIENT PLANNED - Get desktop client area
  • DESKTOP GET LOC PLANNED - Get desktop location
  • DESKTOP GET PPI PLANNED - Get pixels per inch
  • DESKTOP GET SIZE PLANNED - Get display size
  • DIALOG DISABLE PLANNED - Disable dialog window
  • DIALOG DOEVENTS PLANNED - Process pending messages
  • DIALOG ENABLE PLANNED - Enable dialog window
  • DIALOG END PLANNED - Terminate dialog execution
  • DIALOG FONT PLANNED - Set dialog font
  • DIALOG GET CLIENT PLANNED - Get client area info
  • DIALOG GET LOC PLANNED - Get position coordinates
  • DIALOG GET SIZE PLANNED - Get dimensions
  • DIALOG GET TEXT PLANNED - Get window title/text
  • DIALOG GET USER PLANNED - Get user data pointer
  • DIALOG HIDE PLANNED - Hide dialog from view
  • DIALOG MAXIMIZE PLANNED - Maximize dialog window
  • DIALOG MINIMIZE PLANNED - Minimize dialog window
  • DIALOG NEW PLANNED - Create new dialog window
  • DIALOG NONSTABLE PLANNED - Non-stable dialog behavior
  • DIALOG NORMALIZE PLANNED - Normalize coordinates
  • DIALOG PIXELS PLANNED - Convert to pixel units
  • DIALOG POST PLANNED - Post message to dialog
  • DIALOG REDRAW PLANNED - Force redraw of dialog
  • DIALOG SEND PLANNED - Send message to dialog
  • DIALOG SET CLIENT PLANNED - Set client area info
  • DIALOG SET COLOR PLANNED - Set colors
  • DIALOG SET ICON PLANNED - Set window icon
  • DIALOG SET LOC PLANNED - Move dialog position
  • DIALOG SET SIZE PLANNED - Resize dialog
  • DIALOG SET TEXT PLANNED - Change title/text
  • DIALOG SET USER PLANNED - Set user data pointer
  • DIALOG SHOW MODAL PLANNED - Show modal dialog
  • DIALOG SHOW MODELESS PLANNED - Show modeless dialog
  • DIALOG SHOW STATE PLANNED - Get show state
  • DIALOG STABILIZE PLANNED - Stabilize dialog behavior
  • DIALOG UNITS PLANNED - Convert to dialog units
  • DIALOG XLAT PLANNED - Translate coordinates
  • DIM STATEMENT ACTIVE_BASELINE - Declare variables and arrays
  • DISPLAY BROWSE PLANNED - Browse for files/folders
  • DISPLAY COLOR PLANNED - Display color picker
  • DISPLAY FONT PLANNED - Display font selector
  • DISPLAY OPENFILE PLANNED - Open file dialog
  • DISPLAY SAVEFILE PLANNED - Save file dialog
  • ENUM ACTIVE_BASELINE - Enumeration definition
  • ENVIRON ACTIVE_BASELINE - Set environment variable
  • EOF FUNCTION PLANNED - Test end-of-file condition
  • ERASE STATEMENT ACTIVE_BASELINE - Reset or deallocate arrays
  • ERR$ FUNCTION PLANNED - Get error message string
  • ERRLINE FUNCTION PLANNED - Get error line number
  • ERRLINE$ FUNCTION PLANNED - Get error line text
  • ERRNO FUNCTION PLANNED - Get error number
  • ERROR 0 EXCLUDED_NONCOMPILER - No error condition
  • ERROR 11 EXCLUDED_NONCOMPILER - Division by zero
  • ERROR 24 EXCLUDED_NONCOMPILER - Device timeout
  • ERROR 241 EXCLUDED_NONCOMPILER - Global memory corrupt
  • ERROR 242 EXCLUDED_NONCOMPILER - String space corrupt
  • ERROR 401 EXCLUDED_NONCOMPILER - Expression too long/complex
  • ERROR 402 EXCLUDED_NONCOMPILER - Statement too long/complex
  • ERROR 403 EXCLUDED_NONCOMPILER - IF nesting overflow
  • ERROR 404 EXCLUDED_NONCOMPILER - Include file macro nesting overflow
  • ERROR 405 EXCLUDED_NONCOMPILER - Block nesting overflow
  • ERROR 406 EXCLUDED_NONCOMPILER - Compiler out of memory
  • ERROR 407 EXCLUDED_NONCOMPILER - Source line too long
  • ERROR 408 EXCLUDED_NONCOMPILER - Wrong compiler for program
  • ERROR 409 EXCLUDED_NONCOMPILER - Sub/function/method too large
  • ERROR 411-417 PLANNED - Various expected errors
  • ERROR 418 EXCLUDED_NONCOMPILER - Statement expected
  • ERROR 419 EXCLUDED_NONCOMPILER - Label/line number expected
  • ERROR 420 EXCLUDED_NONCOMPILER - Relational operator expected
  • ERROR 421 EXCLUDED_NONCOMPILER - String operand expected
  • ERROR 422-426 PLANNED - Variable type expected errors
  • ERROR 427-429 PLANNED - Constant type expected errors
  • ERROR 430-433 PLANNED - Numeric variable expected errors
  • ERROR 434-458 PLANNED - Syntax element expected errors
  • ERROR 459 EXCLUDED_NONCOMPILER - NEXT expected (FOR loop)
  • ERROR 460+ PLANNED - Various undefined/reference errors
  • EXIT DO ACTIVE_BASELINE - Exit DO loop early
  • EXIT FOR ACTIVE_BASELINE - Exit FROM loop early
  • EXIT PROGRAM ACTIVE_BASELINE - Exit program with code
  • EXIT SELECT ACTIVE_BASELINE - Exit SELECT CASE early
  • EXIT SUB/EXIT FUNCTION ACTIVE_BASELINE - Exit subroutine/function
  • FIELD ACTIVE_BASELINE - Define random file fields
  • FILE ATTRIBS FUNCTION PLANNED - Get file attributes
  • FILE ATTRIBUTES PLANNED - File attribute flags
  • FILE EXIST PLANNED - Check if file exists (FileExists)
  • FILECOPY ACTIVE_BASELINE - Copy file
  • FILES ACTIVE_BASELINE - List files in directory (alternative)
  • FIND TEXT EXCLUDED_NONCOMPILER - Search text in file
  • FLOATING POINT TYPES ACTIVE_BASELINE - Floating point data types
  • GET ACTIVE_BASELINE - Read from random/binary file
  • GET$ ACTIVE_BASELINE - Get string from file
  • GLOBAL ACTIVE_BASELINE - Global variable declaration
  • GOSUB ACTIVE_BASELINE - Subroutine call
  • GOTO ACTIVE_BASELINE - Unconditional branch
  • GOTO BOOKMARK EXCLUDED_NONCOMPILER - Jump to bookmark
  • GOTO LINE EXCLUDED_NONCOMPILER - Go to specific line number
  • GOTO LINE DIALOG EXCLUDED_NONCOMPILER - Line goto dialog
  • GOTOBUTTON PLANNED - Button navigation (DDT)
  • HELP EXCLUDED_NONCOMPILER - Display help system
  • HEX$ FUNCTION PLANNED - Convert to hexadecimal string
  • IF THEN ELSE ACTIVE_BASELINE - Conditional execution statement
  • IN OPERATOR PLANNED - Check if in collection
  • INCR / DECR ACTIVE_BASELINE - Increment/decrement variable
  • INPUT # STATEMENT ACTIVE_BASELINE - Read from sequential file
  • INSERT ITEM PLANNED - Insert into listbox/combo
  • INSTR FUNCTION PLANNED - Find substring position
  • ITERATE ACTIVE_BASELINE - Continue loop iteration
  • JPEG IMAGE DISPLAY PLANNED - Display JPEG images
  • KERNEL FUNCTIONS PLANNED - Windows kernel functions (API)
  • KEYBOARD STATE PLANNED - Check keyboard state
  • KILL ACTIVE_BASELINE - Delete file from disk
  • LCASE$ FUNCTION PLANNED - Convert to lowercase
  • LEFT$ FUNCTION PLANNED - Extract leftmost characters
  • LEN FUNCTION ACTIVE_BASELINE - Get string length
  • LINE PLANNED - Draw line on graphics output
  • LINE INPUT # STATEMENT ACTIVE_BASELINE - Read entire line from file
  • LISTBOX ADD ITEM PLANNED - Add item to listbox
  • LISTBOX DELETE ITEM PLANNED - Delete item from listbox
  • LISTBOX SELECT PLANNED - Select item in listbox
  • LOCAL ACTIVE_BASELINE - Local variable declaration
  • LOCK ACTIVE_BASELINE - Lock file region
  • MAT ACTIVE_BASELINE - Matrix operations
  • MAXIMIZE WINDOW PLANNED - Maximize window (alternative)
  • MID$ FUNCTION PLANNED - Extract substring
  • MINIMIZE WINDOW PLANNED - Minimize window (alternative)
  • MKDIR STATEMENT PLANNED - Create directory
  • MODULE ACTIVE_BASELINE - Define module/section
  • MSGBOX ACTIVE_BASELINE - Message box dialog
  • NEXT STATEMENT ACTIVE_BASELINE - FOR loop counter increment
  • NOT OPERATOR ACTIVE_BASELINE - Logical negation operator
  • ON ERROR GOTO ACTIVE_BASELINE - Error handling handler
  • ON KEY DOWN PLANNED - Keyboard event handling
  • ON KEY UP PLANNED - Keyboard event handling
  • OPEN STATEMENT ACTIVE_BASELINE - Open file for I/O operations
  • OPTION BASE PLANNED - Default array lower bound
  • OR OPERATOR ACTIVE_BASELINE - Bitwise and logical operator
  • PAINT PLANNED - Fill enclosed area on graphics output
  • PARSE COMMAND LINE PLANNED - Parse command-line arguments
  • PASSWORD FIELD PLANNED - Edit box with masking
  • PATH NAME PLANNED - File path manipulation
  • PBWIN COMPILER EXCLUDED_NONCOMPILER - PowerBasic Windows compiler
  • PEEK FUNCTION ACTIVE_BASELINE - Read from memory address
  • PERMANENT STORAGE PLANNED - Persistent data storage
  • PILOT Language Adapter ACTIVE_BASELINE - PILOT language pipeline adapter
  • PLACEHOLDER EXCLUDED_NONCOMPILER - Placeholder text/function
  • POINT PLANNED - Get mouse position
  • POKE ACTIVE_BASELINE - Write to memory address
  • POPUP MENU PLANNED - Display context menu
  • POWERSHELL EXECUTION EXCLUDED_NONCOMPILER - Run PowerShell commands
  • PRINT # ACTIVE_BASELINE - Print to file
  • PROFILE ACTIVE_BASELINE - Performance profile
  • PUT$ ACTIVE_BASELINE - Put string to file
  • QUESTION MARK EXCLUDED_NONCOMPILER - Wildcard character
  • RANDOM ACCESS FILE PLANNED - Random file I/O mode
  • RANDOMIZE ACTIVE_BASELINE - Seed random number generator
  • READ ACTIVE_BASELINE - Read from DATA
  • READ FROM MEMORY PLANNED - Read memory locations (alternative)
  • REDIM STATEMENT ACTIVE_BASELINE - Redimension array size
  • REGISTER KEY PLANNED - Registry key operations
  • REGISTRY OPERATIONS PLANNED - Windows registry access
  • REPLACE ACTIVE_BASELINE - String replacement
  • RESTORE ACTIVE_BASELINE - Reset DATA pointer
  • RESUME ACTIVE_BASELINE - Resume after error
  • RETURN ACTIVE_BASELINE - Return from subroutine/function
  • RIGHT$ FUNCTION PLANNED - Extract rightmost characters
  • RND FUNCTION PLANNED - Random number generator
  • ROUND FUNCTION PLANNED - Round numeric value
  • RUN APPLICATION PLANNED - Run external applications
  • SCREEN STATEMENT PLANNED - Set active graphics screen
  • SEARCH IN FILES EXCLUDED_NONCOMPILER - Recursive file search
  • SELECT CASE ACTIVE_BASELINE - Multiple choice statement
  • SEND MESSAGE PLANNED - Send message to window/control
  • SET FOCUS PLANNED - Give keyboard focus (alternative)
  • SET FONT PLANNED - Change font (alternative)
  • SETATTR ACTIVE_BASELINE - Set file attributes
  • SETEOF ACTIVE_BASELINE - Set end of file
  • SHELL STATEMENT ACTIVE_BASELINE - Run external program
  • SHOW WINDOW PLANNED - Show window state
  • SLEEP ACTIVE_BASELINE - Pause execution
  • STATIC ACTIVE_BASELINE - Static variable declaration
  • STRING OPERATIONS EXCLUDED_NONCOMPILER - String manipulation functions
  • SUB FUNCTION METHOD PROPERTY ACTIVE_BASELINE - Object members
  • SUBTRACT OPERATOR ACTIVE_BASELINE - Arithmetic subtraction
  • SUM ARRAY PLANNED - Sum array elements (PowerArray)
  • THINPRINT ACTIVE_BASELINE - Thin client print
  • TRACE ACTIVE_BASELINE - Debug trace
  • TRY / CATCH / FINALLY ACTIVE_BASELINE - Structured exception handling
  • UCASE$ FUNCTION PLANNED - Convert to uppercase
  • UNION ACTIVE_BASELINE - Union definition
  • UNLOAD MODULE PLANNED - Unload external module
  • UNLOCK ACTIVE_BASELINE - Unlock file region
  • UPDATE RECORD PLANNED - Update random access record
  • VAL FUNCTION PLANNED - Convert string to number
  • VARIABLES EXCLUDED_NONCOMPILER - Variable declaration and usage
  • VERSION INFORMATION EXCLUDED_NONCOMPILER - Application version data
  • WIDTH ACTIVE_BASELINE - Console/file width
  • WITH ACTIVE_BASELINE - UDT context block
  • WRITE # ACTIVE_BASELINE - Write to file
  • WRITE # STATEMENT ACTIVE_BASELINE - Write formatted data to file
  • WRITE TO MEMORY PLANNED - Write memory locations (alternative)
  • ZERO BASED ARRAYS ACTIVE_BASELINE - Zero-indexed array access


#ASM / #ENDASM - CompilerX64 Help

#ASM / #ENDASM

Inline assembly block

Kind | Statement
Lane | ASM
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_asm_bridge_array_udt.ps1
Probe status |
F1 keywords | #ASM / #ENDASM, #ASM, #ENDASM

Syntax

#ASM / #ENDASM [arguments]

Usage Examples

  1. #ASM / #ENDASM
  2. #ASM / #ENDASM argument1, argument2
  3. IF condition THEN #ASM / #ENDASM

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.

Back to command index


#CINCLUDE / #CCODE - CompilerX64 Help

#CINCLUDE / #CCODE

C language interop

Kind | Statement
Lane | PB-Interop
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_cinclude_bridge.ps1
Probe status |
F1 keywords | #CINCLUDE / #CCODE, #CINCLUDE, #CCODE

Syntax

#CINCLUDE / #CCODE [arguments]

Usage Examples

  1. #CINCLUDE / #CCODE
  2. #CINCLUDE / #CCODE argument1, argument2
  3. IF condition THEN #CINCLUDE / #CCODE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


#PCODE / #ENDP - CompilerX64 Help

#PCODE / #ENDP

PILOT code block

Kind | Statement
Lane | PB-Interop
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_embedded_blocks_pcode_contract.ps1
Probe status |
F1 keywords | #PCODE / #ENDP, #PCODE, #ENDP

Syntax

#PCODE / #ENDP [arguments]

Usage Examples

  1. #PCODE / #ENDP
  2. #PCODE / #ENDP argument1, argument2
  3. IF condition THEN #PCODE / #ENDP

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ACCEL ATTACH - CompilerX64 Help

ACCEL ATTACH

Attach keyboard accelerator table to dialog

Kind | Topic
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ACCEL ATTACH, ACCEL, ATTACH

Syntax

ACCEL ATTACH [arguments]

Usage Examples

  1. ACCEL ATTACH
  2. ACCEL ATTACH argument1, argument2
  3. IF condition THEN ACCEL ATTACH

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ACCELERATOR - CompilerX64 Help

ACCELERATOR

Define keyboard accelerators (alternative)

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ACCELERATOR

Syntax

ACCELERATOR [arguments]

Usage Examples

  1. ACCELERATOR
  2. ACCELERATOR argument1, argument2
  3. IF condition THEN ACCELERATOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ADDITEM - CompilerX64 Help

ADDITEM

Add item to listbox/combo/listview control

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ADDITEM

Syntax

ADDITEM [arguments]

Usage Examples

  1. ADDITEM
  2. ADDITEM argument1, argument2
  3. IF condition THEN ADDITEM

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


AND OPERATOR - CompilerX64 Help

AND OPERATOR

Bitwise and logical operator

Kind | Operator
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_expression_semantics.ps1
Probe status |
F1 keywords | AND OPERATOR, AND

Syntax

result = left_operand AND right_operand

Usage Examples

  1. AND OPERATOR
  2. AND OPERATOR argument1, argument2
  3. IF condition THEN AND OPERATOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


APPENDIX_A_LICENSE_AGREEMENT - CompilerX64 Help

APPENDIX_A_LICENSE_AGREEMENT

License information

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | APPENDIX_A_LICENSE_AGREEMENT

Syntax

APPENDIX_A_LICENSE_AGREEMENT [arguments]

Usage Examples

  1. APPENDIX_A_LICENSE_AGREEMENT
  2. APPENDIX_A_LICENSE_AGREEMENT argument1, argument2
  3. IF condition THEN APPENDIX_A_LICENSE_AGREEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ARRAY ASSIGN - CompilerX64 Help

ARRAY ASSIGN

Assign array

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_arraycore.ps1
Probe status |
F1 keywords | ARRAY ASSIGN, ARRAY, ASSIGN

Syntax

ARRAY ASSIGN [arguments]

Usage Examples

  1. ARRAY ASSIGN
  2. ARRAY ASSIGN argument1, argument2
  3. IF condition THEN ARRAY ASSIGN

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ARRAY DELETE - CompilerX64 Help

ARRAY DELETE

Delete array element

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_arraycore.ps1
Probe status |
F1 keywords | ARRAY DELETE, ARRAY, DELETE

Syntax

ARRAY DELETE [arguments]

Usage Examples

  1. ARRAY DELETE
  2. ARRAY DELETE argument1, argument2
  3. IF condition THEN ARRAY DELETE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ARRAY INSERT - CompilerX64 Help

ARRAY INSERT

Insert array element

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_arraycore.ps1
Probe status |
F1 keywords | ARRAY INSERT, ARRAY, INSERT

Syntax

ARRAY INSERT [arguments]

Usage Examples

  1. ARRAY INSERT
  2. ARRAY INSERT argument1, argument2
  3. IF condition THEN ARRAY INSERT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ARRAY SCAN - CompilerX64 Help

ARRAY SCAN

Search array

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_arraycore.ps1
Probe status |
F1 keywords | ARRAY SCAN, ARRAY, SCAN

Syntax

ARRAY SCAN [arguments]

Usage Examples

  1. ARRAY SCAN
  2. ARRAY SCAN argument1, argument2
  3. IF condition THEN ARRAY SCAN

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ARRAY SORT - CompilerX64 Help

ARRAY SORT

Sort array

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_arraycore.ps1
Probe status |
F1 keywords | ARRAY SORT, ARRAY, SORT

Syntax

ARRAY SORT [arguments]

Usage Examples

  1. ARRAY SORT
  2. ARRAY SORT argument1, argument2
  3. IF condition THEN ARRAY SORT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ASC FUNCTION - CompilerX64 Help

ASC FUNCTION

Return ASCII code for character

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ASC FUNCTION, ASC

Syntax

result = ASC(string_expression [, position])

Usage Examples

  1. ASC FUNCTION
  2. ASC FUNCTION argument1, argument2
  3. IF condition THEN ASC FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ASC STATEMENT - CompilerX64 Help

ASC STATEMENT

Alternative syntax

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ASC STATEMENT, ASC

Syntax

ASC STATEMENT [arguments]

Usage Examples

  1. ASC STATEMENT
  2. ASC STATEMENT argument1, argument2
  3. IF condition THEN ASC STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ASSERT - CompilerX64 Help

ASSERT

Debug assertion statement

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | ASSERT

Syntax

ASSERT [arguments]

Usage Examples

  1. ASSERT
  2. ASSERT argument1, argument2
  3. IF condition THEN ASSERT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ASSIGN STATEMENT - CompilerX64 Help

ASSIGN STATEMENT

Assign array values

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_expression_semantics.ps1
Probe status |
F1 keywords | ASSIGN STATEMENT, ASSIGN

Syntax

ASSIGN STATEMENT [arguments]

Usage Examples

  1. ASSIGN STATEMENT
  2. ASSIGN STATEMENT argument1, argument2
  3. IF condition THEN ASSIGN STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ATN FUNCTION - CompilerX64 Help

ATN FUNCTION

Arctangent calculation

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ATN FUNCTION, ATN

Syntax

result = ATN FUNCTION(...)

Usage Examples

  1. ATN FUNCTION
  2. ATN FUNCTION argument1, argument2
  3. IF condition THEN ATN FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


BACKSPACE - CompilerX64 Help

BACKSPACE

Keyboard escape sequence

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | BACKSPACE

Syntax

BACKSPACE [arguments]

Usage Examples

  1. BACKSPACE
  2. BACKSPACE argument1, argument2
  3. IF condition THEN BACKSPACE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


BEEP - CompilerX64 Help

BEEP

Console beep

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_beep_runtime.ps1
Probe status |
F1 keywords | BEEP

Syntax

BEEP [arguments]

Usage Examples

  1. BEEP
  2. BEEP argument1, argument2
  3. IF condition THEN BEEP

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


C99 Language Adapter - CompilerX64 Help

C99 Language Adapter

C99 language pipeline adapter

Kind | Adapter
Lane | PB-Interop
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_cinclude_bridge.ps1
Probe status |
F1 keywords | C99 Language Adapter, C99, Language, Adapter

Syntax

C99 Language Adapter [arguments]

Usage Examples

  1. C99 Language Adapter
  2. C99 Language Adapter argument1, argument2
  3. IF condition THEN C99 Language Adapter

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CALL - CompilerX64 Help

CALL

Call subroutine/function (alternative)

Kind | Function
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_call_targets.ps1; scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | CALL

Syntax

CALL procedure_name[(arguments)]

Usage Examples

  1. CALL
  2. CALL argument1, argument2
  3. IF condition THEN CALL

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CALLBACK - CompilerX64 Help

CALLBACK

Define callback functions

Kind | Family
Lane | PB-Objects
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | CALLBACK

Syntax

CALLBACK [arguments]

Usage Examples

  1. CALLBACK
  2. CALLBACK argument1, argument2
  3. IF condition THEN CALLBACK

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CALLSTK - CompilerX64 Help

CALLSTK

Get stack information

Kind | Topic
Lane | ASM
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CALLSTK

Syntax

CALLSTK [arguments]

Usage Examples

  1. CALLSTK
  2. CALLSTK argument1, argument2
  3. IF condition THEN CALLSTK

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CALLSTKCOUNT - CompilerX64 Help

CALLSTKCOUNT

Count stack depth

Kind | Topic
Lane | ASM
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CALLSTKCOUNT

Syntax

CALLSTKCOUNT [arguments]

Usage Examples

  1. CALLSTKCOUNT
  2. CALLSTKCOUNT argument1, argument2
  3. IF condition THEN CALLSTKCOUNT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CANCEL - CompilerX64 Help

CANCEL

Dialog button identifier (%IDCANCEL)

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CANCEL

Syntax

CANCEL [arguments]

Usage Examples

  1. CANCEL
  2. CANCEL argument1, argument2
  3. IF condition THEN CANCEL

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CAPSLOCK - CompilerX64 Help

CAPSLOCK

Keyboard state check

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CAPSLOCK

Syntax

CAPSLOCK [arguments]

Usage Examples

  1. CAPSLOCK
  2. CAPSLOCK argument1, argument2
  3. IF condition THEN CAPSLOCK

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CASE - CompilerX64 Help

CASE

SELECT CASE clause

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CASE

Syntax

CASE [arguments]

Usage Examples

  1. CASE
  2. CASE argument1, argument2
  3. IF condition THEN CASE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CB - CompilerX64 Help

CB

Callback function parameters (CB.CTL, CB.MSG, etc.)

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CB

Syntax

result = CB(...)

Usage Examples

  1. CB
  2. CB argument1, argument2
  3. IF condition THEN CB

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CDWD FUNCTION - CompilerX64 Help

CDWD FUNCTION

Convert to double word

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CDWD FUNCTION, CDWD

Syntax

result = CDWD FUNCTION(...)

Usage Examples

  1. CDWD FUNCTION
  2. CDWD FUNCTION argument1, argument2
  3. IF condition THEN CDWD FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CHDIR STATEMENT - CompilerX64 Help

CHDIR STATEMENT

Change current directory

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CHDIR STATEMENT, CHDIR

Syntax

CHDIR STATEMENT [arguments]

Usage Examples

  1. CHDIR STATEMENT
  2. CHDIR STATEMENT argument1, argument2
  3. IF condition THEN CHDIR STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CHDRIVE STATEMENT - CompilerX64 Help

CHDRIVE STATEMENT

Change disk drive

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification |
Probe status |
F1 keywords | CHDRIVE STATEMENT, CHDRIVE

Syntax

CHDRIVE STATEMENT [arguments]

Usage Examples

  1. CHDRIVE STATEMENT
  2. CHDRIVE STATEMENT argument1, argument2
  3. IF condition THEN CHDRIVE STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CHR$ FUNCTION - CompilerX64 Help

CHR$ FUNCTION

Convert ASCII code to character

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CHR$ FUNCTION, CHR$

Syntax

result$ = CHR$(codepoint)

Usage Examples

  1. CHR$ FUNCTION
  2. CHR$ FUNCTION argument1, argument2
  3. IF condition THEN CHR$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CIRCLE - CompilerX64 Help

CIRCLE

Draw circle/arc on graphics output

Kind | Topic
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CIRCLE

Syntax

CIRCLE [arguments]

Usage Examples

  1. CIRCLE
  2. CIRCLE argument1, argument2
  3. IF condition THEN CIRCLE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CLEAR - CompilerX64 Help

CLEAR

Clear screen and variables

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CLEAR

Syntax

CLEAR [arguments]

Usage Examples

  1. CLEAR
  2. CLEAR argument1, argument2
  3. IF condition THEN CLEAR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CLOSE - CompilerX64 Help

CLOSE

Close file handle

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_file_openclose.ps1
Probe status |
F1 keywords | CLOSE

Syntax

CLOSE [#]filenum [, [#]filenum ...]

Usage Examples

  1. CLOSE
  2. CLOSE argument1, argument2
  3. IF condition THEN CLOSE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; runtime I/O helper call
lea     rcx, [file_descriptor]
call    cx64_file_io_helper
; status/result in rax

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CLR - CompilerX64 Help

CLR

Color reset statement

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CLR

Syntax

CLR [arguments]

Usage Examples

  1. CLR
  2. CLR argument1, argument2
  3. IF condition THEN CLR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CLS - CompilerX64 Help

CLS

Clear screen/picture window

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | CLS

Syntax

CLS [arguments]

Usage Examples

  1. CLS
  2. CLS argument1, argument2
  3. IF condition THEN CLS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CLSID FUNCTION - CompilerX64 Help

CLSID FUNCTION

Get class identifier

Kind | Function
Lane | PB-Objects
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CLSID FUNCTION, CLSID

Syntax

result = CLSID FUNCTION(...)

Usage Examples

  1. CLSID FUNCTION
  2. CLSID FUNCTION argument1, argument2
  3. IF condition THEN CLSID FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CODEPTR FUNCTION - CompilerX64 Help

CODEPTR FUNCTION

Get code pointer/address

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CODEPTR FUNCTION, CODEPTR

Syntax

result = CODEPTR FUNCTION(...)

Usage Examples

  1. CODEPTR FUNCTION
  2. CODEPTR FUNCTION argument1, argument2
  3. IF condition THEN CODEPTR FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COLLECTION OBJECT - CompilerX64 Help

COLLECTION OBJECT

Collection data structure

Kind | Family
Lane | PB-Objects
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COLLECTION OBJECT, COLLECTION, OBJECT

Syntax

COLLECTION OBJECT [arguments]

Usage Examples

  1. COLLECTION OBJECT
  2. COLLECTION OBJECT argument1, argument2
  3. IF condition THEN COLLECTION OBJECT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COLOR - CompilerX64 Help

COLOR

Set foreground/background colors

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COLOR

Syntax

COLOR [arguments]

Usage Examples

  1. COLOR
  2. COLOR argument1, argument2
  3. IF condition THEN COLOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COM - CompilerX64 Help

COM

Communications port functions

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COM

Syntax

COM [arguments]

Usage Examples

  1. COM
  2. COM argument1, argument2
  3. IF condition THEN COM

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COM OBJECTS - CompilerX64 Help

COM OBJECTS

Component Object Model support

Kind | Family
Lane | PB-Objects
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COM OBJECTS, COM, OBJECTS

Syntax

COM OBJECTS [arguments]

Usage Examples

  1. COM OBJECTS
  2. COM OBJECTS argument1, argument2
  3. IF condition THEN COM OBJECTS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMM CLOSE - CompilerX64 Help

COMM CLOSE

Close communication port

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMM CLOSE, COMM, CLOSE

Syntax

COMM CLOSE [arguments]

Usage Examples

  1. COMM CLOSE
  2. COMM CLOSE argument1, argument2
  3. IF condition THEN COMM CLOSE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMM OPEN - CompilerX64 Help

COMM OPEN

Open serial communications port

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMM OPEN, COMM, OPEN

Syntax

COMM OPEN [arguments]

Usage Examples

  1. COMM OPEN
  2. COMM OPEN argument1, argument2
  3. IF condition THEN COMM OPEN

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMM PRINT - CompilerX64 Help

COMM PRINT

Send data to communications device

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMM PRINT, COMM, PRINT

Syntax

COMM PRINT [arguments]

Usage Examples

  1. COMM PRINT
  2. COMM PRINT argument1, argument2
  3. IF condition THEN COMM PRINT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMM RECEIVE - CompilerX64 Help

COMM RECEIVE

Receive data from communications device

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMM RECEIVE, COMM, RECEIVE

Syntax

COMM RECEIVE [arguments]

Usage Examples

  1. COMM RECEIVE
  2. COMM RECEIVE argument1, argument2
  3. IF condition THEN COMM RECEIVE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMM RESET - CompilerX64 Help

COMM RESET

Reset communication port

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMM RESET, COMM, RESET

Syntax

COMM RESET [arguments]

Usage Examples

  1. COMM RESET
  2. COMM RESET argument1, argument2
  3. IF condition THEN COMM RESET

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMM SEND - CompilerX64 Help

COMM SEND

Send data (alternative)

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMM SEND, COMM, SEND

Syntax

COMM SEND [arguments]

Usage Examples

  1. COMM SEND
  2. COMM SEND argument1, argument2
  3. IF condition THEN COMM SEND

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMM SET - CompilerX64 Help

COMM SET

Configure communication parameters

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMM SET, COMM, SET

Syntax

COMM SET [arguments]

Usage Examples

  1. COMM SET
  2. COMM SET argument1, argument2
  3. IF condition THEN COMM SET

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMM TIMEOUT - CompilerX64 Help

COMM TIMEOUT

Set receive timeout

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMM TIMEOUT, COMM, TIMEOUT

Syntax

COMM TIMEOUT [arguments]

Usage Examples

  1. COMM TIMEOUT
  2. COMM TIMEOUT argument1, argument2
  3. IF condition THEN COMM TIMEOUT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMMAND FUNCTION - CompilerX64 Help

COMMAND FUNCTION

Get command line arguments

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMMAND FUNCTION, COMMAND

Syntax

result = COMMAND FUNCTION(...)

Usage Examples

  1. COMMAND FUNCTION
  2. COMMAND FUNCTION argument1, argument2
  3. IF condition THEN COMMAND FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMPARATIVE DATA TYPES C/C++ - CompilerX64 Help

COMPARATIVE DATA TYPES C/C++

Type comparisons with C/C++

Kind | Datatype
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | COMPARATIVE DATA TYPES C/C++, COMPARATIVE, DATA, TYPES, C++

Syntax

COMPARATIVE DATA TYPES C/C++ [arguments]

Usage Examples

  1. COMPARATIVE DATA TYPES C/C++
  2. COMPARATIVE DATA TYPES C/C++ argument1, argument2
  3. IF condition THEN COMPARATIVE DATA TYPES C/C++

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMPARE OPERATOR - CompilerX64 Help

COMPARE OPERATOR

String comparison operator

Kind | Operator
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | COMPARE OPERATOR, COMPARE

Syntax

result = left_operand COMPARE right_operand

Usage Examples

  1. COMPARE OPERATOR
  2. COMPARE OPERATOR argument1, argument2
  3. IF condition THEN COMPARE OPERATOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMPILE FUNCTIONS - CompilerX64 Help

COMPILE FUNCTIONS

Compiler directives and functions

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | COMPILE FUNCTIONS, COMPILE, FUNCTIONS

Syntax

COMPILE FUNCTIONS [arguments]

Usage Examples

  1. COMPILE FUNCTIONS
  2. COMPILE FUNCTIONS argument1, argument2
  3. IF condition THEN COMPILE FUNCTIONS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


COMPILE PREFERENCES - CompilerX64 Help

COMPILE PREFERENCES

IDE compilation settings

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | COMPILE PREFERENCES, COMPILE, PREFERENCES

Syntax

COMPILE PREFERENCES [arguments]

Usage Examples

  1. COMPILE PREFERENCES
  2. COMPILE PREFERENCES argument1, argument2
  3. IF condition THEN COMPILE PREFERENCES

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONST - CompilerX64 Help

CONST

Constant declaration

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | CONST

Syntax

CONST [arguments]

Usage Examples

  1. CONST
  2. CONST argument1, argument2
  3. IF condition THEN CONST

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD BUTTON - CompilerX64 Help

CONTROL ADD BUTTON

Add command button control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD BUTTON, CONTROL, ADD, BUTTON

Syntax

CONTROL ADD BUTTON [arguments]

Usage Examples

  1. CONTROL ADD BUTTON
  2. CONTROL ADD BUTTON argument1, argument2
  3. IF condition THEN CONTROL ADD BUTTON

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD CHECKBOX - CompilerX64 Help

CONTROL ADD CHECKBOX

Add checkbox control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD CHECKBOX, CONTROL, ADD, CHECKBOX

Syntax

CONTROL ADD CHECKBOX [arguments]

Usage Examples

  1. CONTROL ADD CHECKBOX
  2. CONTROL ADD CHECKBOX argument1, argument2
  3. IF condition THEN CONTROL ADD CHECKBOX

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD COMBOBOX - CompilerX64 Help

CONTROL ADD COMBOBOX

Add combo box control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD COMBOBOX, CONTROL, ADD, COMBOBOX

Syntax

CONTROL ADD COMBOBOX [arguments]

Usage Examples

  1. CONTROL ADD COMBOBOX
  2. CONTROL ADD COMBOBOX argument1, argument2
  3. IF condition THEN CONTROL ADD COMBOBOX

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD FRAME - CompilerX64 Help

CONTROL ADD FRAME

Add frame/groupbox control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD FRAME, CONTROL, ADD, FRAME

Syntax

CONTROL ADD FRAME [arguments]

Usage Examples

  1. CONTROL ADD FRAME
  2. CONTROL ADD FRAME argument1, argument2
  3. IF condition THEN CONTROL ADD FRAME

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD GRAPHIC - CompilerX64 Help

CONTROL ADD GRAPHIC

Add graphic/image control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD GRAPHIC, CONTROL, ADD, GRAPHIC

Syntax

CONTROL ADD GRAPHIC [arguments]

Usage Examples

  1. CONTROL ADD GRAPHIC
  2. CONTROL ADD GRAPHIC argument1, argument2
  3. IF condition THEN CONTROL ADD GRAPHIC

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD HEADER - CompilerX64 Help

CONTROL ADD HEADER

Add header control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD HEADER, CONTROL, ADD, HEADER

Syntax

CONTROL ADD HEADER [arguments]

Usage Examples

  1. CONTROL ADD HEADER
  2. CONTROL ADD HEADER argument1, argument2
  3. IF condition THEN CONTROL ADD HEADER

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD IMAGE - CompilerX64 Help

CONTROL ADD IMAGE

Add image display control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD IMAGE, CONTROL, ADD, IMAGE

Syntax

CONTROL ADD IMAGE [arguments]

Usage Examples

  1. CONTROL ADD IMAGE
  2. CONTROL ADD IMAGE argument1, argument2
  3. IF condition THEN CONTROL ADD IMAGE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD IMGBUTTON - CompilerX64 Help

CONTROL ADD IMGBUTTON

Add button with image

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD IMGBUTTON, CONTROL, ADD, IMGBUTTON

Syntax

CONTROL ADD IMGBUTTON [arguments]

Usage Examples

  1. CONTROL ADD IMGBUTTON
  2. CONTROL ADD IMGBUTTON argument1, argument2
  3. IF condition THEN CONTROL ADD IMGBUTTON

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD LABEL - CompilerX64 Help

CONTROL ADD LABEL

Add static text label

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD LABEL, CONTROL, ADD, LABEL

Syntax

CONTROL ADD LABEL [arguments]

Usage Examples

  1. CONTROL ADD LABEL
  2. CONTROL ADD LABEL argument1, argument2
  3. IF condition THEN CONTROL ADD LABEL

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD LINE - CompilerX64 Help

CONTROL ADD LINE

Add line drawing control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD LINE, CONTROL, ADD, LINE

Syntax

CONTROL ADD LINE [arguments]

Usage Examples

  1. CONTROL ADD LINE
  2. CONTROL ADD LINE argument1, argument2
  3. IF condition THEN CONTROL ADD LINE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD LISTBOX - CompilerX64 Help

CONTROL ADD LISTBOX

Add listbox control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD LISTBOX, CONTROL, ADD, LISTBOX

Syntax

CONTROL ADD LISTBOX [arguments]

Usage Examples

  1. CONTROL ADD LISTBOX
  2. CONTROL ADD LISTBOX argument1, argument2
  3. IF condition THEN CONTROL ADD LISTBOX

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD LISTVIEW - CompilerX64 Help

CONTROL ADD LISTVIEW

Add listview control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD LISTVIEW, CONTROL, ADD, LISTVIEW

Syntax

CONTROL ADD LISTVIEW [arguments]

Usage Examples

  1. CONTROL ADD LISTVIEW
  2. CONTROL ADD LISTVIEW argument1, argument2
  3. IF condition THEN CONTROL ADD LISTVIEW

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD OPTION - CompilerX64 Help

CONTROL ADD OPTION

Add option/radio button

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD OPTION, CONTROL, ADD, OPTION

Syntax

CONTROL ADD OPTION [arguments]

Usage Examples

  1. CONTROL ADD OPTION
  2. CONTROL ADD OPTION argument1, argument2
  3. IF condition THEN CONTROL ADD OPTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD PROGRESSBAR - CompilerX64 Help

CONTROL ADD PROGRESSBAR

Add progress bar control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD PROGRESSBAR, CONTROL, ADD, PROGRESSBAR

Syntax

CONTROL ADD PROGRESSBAR [arguments]

Usage Examples

  1. CONTROL ADD PROGRESSBAR
  2. CONTROL ADD PROGRESSBAR argument1, argument2
  3. IF condition THEN CONTROL ADD PROGRESSBAR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD SCROLLBAR - CompilerX64 Help

CONTROL ADD SCROLLBAR

Add scrollbar control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD SCROLLBAR, CONTROL, ADD, SCROLLBAR

Syntax

CONTROL ADD SCROLLBAR [arguments]

Usage Examples

  1. CONTROL ADD SCROLLBAR
  2. CONTROL ADD SCROLLBAR argument1, argument2
  3. IF condition THEN CONTROL ADD SCROLLBAR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD STATUSBAR - CompilerX64 Help

CONTROL ADD STATUSBAR

Add status bar control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD STATUSBAR, CONTROL, ADD, STATUSBAR

Syntax

CONTROL ADD STATUSBAR [arguments]

Usage Examples

  1. CONTROL ADD STATUSBAR
  2. CONTROL ADD STATUSBAR argument1, argument2
  3. IF condition THEN CONTROL ADD STATUSBAR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD TAB - CompilerX64 Help

CONTROL ADD TAB

Add tab control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD TAB, CONTROL, ADD, TAB

Syntax

CONTROL ADD TAB [arguments]

Usage Examples

  1. CONTROL ADD TAB
  2. CONTROL ADD TAB argument1, argument2
  3. IF condition THEN CONTROL ADD TAB

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD TEXTBOX - CompilerX64 Help

CONTROL ADD TEXTBOX

Add text input control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD TEXTBOX, CONTROL, ADD, TEXTBOX

Syntax

CONTROL ADD TEXTBOX [arguments]

Usage Examples

  1. CONTROL ADD TEXTBOX
  2. CONTROL ADD TEXTBOX argument1, argument2
  3. IF condition THEN CONTROL ADD TEXTBOX

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD TOOLBAR - CompilerX64 Help

CONTROL ADD TOOLBAR

Add toolbar control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD TOOLBAR, CONTROL, ADD, TOOLBAR

Syntax

CONTROL ADD TOOLBAR [arguments]

Usage Examples

  1. CONTROL ADD TOOLBAR
  2. CONTROL ADD TOOLBAR argument1, argument2
  3. IF condition THEN CONTROL ADD TOOLBAR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ADD TREEVIEW - CompilerX64 Help

CONTROL ADD TREEVIEW

Add tree view control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ADD TREEVIEW, CONTROL, ADD, TREEVIEW

Syntax

CONTROL ADD TREEVIEW [arguments]

Usage Examples

  1. CONTROL ADD TREEVIEW
  2. CONTROL ADD TREEVIEW argument1, argument2
  3. IF condition THEN CONTROL ADD TREEVIEW

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL DISABLE - CompilerX64 Help

CONTROL DISABLE

Disable control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL DISABLE, CONTROL, DISABLE

Syntax

CONTROL DISABLE [arguments]

Usage Examples

  1. CONTROL DISABLE
  2. CONTROL DISABLE argument1, argument2
  3. IF condition THEN CONTROL DISABLE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL ENABLE - CompilerX64 Help

CONTROL ENABLE

Enable control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL ENABLE, CONTROL, ENABLE

Syntax

CONTROL ENABLE [arguments]

Usage Examples

  1. CONTROL ENABLE
  2. CONTROL ENABLE argument1, argument2
  3. IF condition THEN CONTROL ENABLE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL GET CHECK - CompilerX64 Help

CONTROL GET CHECK

Get checkbox state

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL GET CHECK, CONTROL, GET, CHECK

Syntax

CONTROL GET CHECK [arguments]

Usage Examples

  1. CONTROL GET CHECK
  2. CONTROL GET CHECK argument1, argument2
  3. IF condition THEN CONTROL GET CHECK

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL GET CLIENT - CompilerX64 Help

CONTROL GET CLIENT

Get client area info

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL GET CLIENT, CONTROL, GET, CLIENT

Syntax

CONTROL GET CLIENT [arguments]

Usage Examples

  1. CONTROL GET CLIENT
  2. CONTROL GET CLIENT argument1, argument2
  3. IF condition THEN CONTROL GET CLIENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL GET FONT - CompilerX64 Help

CONTROL GET FONT

Get font information

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL GET FONT, CONTROL, GET, FONT

Syntax

CONTROL GET FONT [arguments]

Usage Examples

  1. CONTROL GET FONT
  2. CONTROL GET FONT argument1, argument2
  3. IF condition THEN CONTROL GET FONT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL GET LOC - CompilerX64 Help

CONTROL GET LOC

Get position coordinates

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL GET LOC, CONTROL, GET, LOC

Syntax

CONTROL GET LOC [arguments]

Usage Examples

  1. CONTROL GET LOC
  2. CONTROL GET LOC argument1, argument2
  3. IF condition THEN CONTROL GET LOC

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL GET SIZE - CompilerX64 Help

CONTROL GET SIZE

Get dimensions

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL GET SIZE, CONTROL, GET, SIZE

Syntax

CONTROL GET SIZE [arguments]

Usage Examples

  1. CONTROL GET SIZE
  2. CONTROL GET SIZE argument1, argument2
  3. IF condition THEN CONTROL GET SIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL GET TEXT - CompilerX64 Help

CONTROL GET TEXT

Get text content

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL GET TEXT, CONTROL, GET, TEXT

Syntax

CONTROL GET TEXT [arguments]

Usage Examples

  1. CONTROL GET TEXT
  2. CONTROL GET TEXT argument1, argument2
  3. IF condition THEN CONTROL GET TEXT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL GET USER - CompilerX64 Help

CONTROL GET USER

Get user data pointer

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL GET USER, CONTROL, GET, USER

Syntax

CONTROL GET USER [arguments]

Usage Examples

  1. CONTROL GET USER
  2. CONTROL GET USER argument1, argument2
  3. IF condition THEN CONTROL GET USER

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL HANDLE - CompilerX64 Help

CONTROL HANDLE

Get control window handle

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL HANDLE, CONTROL, HANDLE

Syntax

CONTROL HANDLE [arguments]

Usage Examples

  1. CONTROL HANDLE
  2. CONTROL HANDLE argument1, argument2
  3. IF condition THEN CONTROL HANDLE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL HIDE - CompilerX64 Help

CONTROL HIDE

Hide control from view

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL HIDE, CONTROL, HIDE

Syntax

CONTROL HIDE [arguments]

Usage Examples

  1. CONTROL HIDE
  2. CONTROL HIDE argument1, argument2
  3. IF condition THEN CONTROL HIDE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL KILL - CompilerX64 Help

CONTROL KILL

Remove/destroy control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL KILL, CONTROL, KILL

Syntax

CONTROL KILL [arguments]

Usage Examples

  1. CONTROL KILL
  2. CONTROL KILL argument1, argument2
  3. IF condition THEN CONTROL KILL

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL NORMALIZE - CompilerX64 Help

CONTROL NORMALIZE

Normalize coordinates

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL NORMALIZE, CONTROL, NORMALIZE

Syntax

CONTROL NORMALIZE [arguments]

Usage Examples

  1. CONTROL NORMALIZE
  2. CONTROL NORMALIZE argument1, argument2
  3. IF condition THEN CONTROL NORMALIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL POST - CompilerX64 Help

CONTROL POST

Post message to control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL POST, CONTROL, POST

Syntax

CONTROL POST [arguments]

Usage Examples

  1. CONTROL POST
  2. CONTROL POST argument1, argument2
  3. IF condition THEN CONTROL POST

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL REDRAW - CompilerX64 Help

CONTROL REDRAW

Force redraw of control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL REDRAW, CONTROL, REDRAW

Syntax

CONTROL REDRAW [arguments]

Usage Examples

  1. CONTROL REDRAW
  2. CONTROL REDRAW argument1, argument2
  3. IF condition THEN CONTROL REDRAW

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SEND - CompilerX64 Help

CONTROL SEND

Send message to control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SEND, CONTROL, SEND

Syntax

CONTROL SEND [arguments]

Usage Examples

  1. CONTROL SEND
  2. CONTROL SEND argument1, argument2
  3. IF condition THEN CONTROL SEND

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET CHECK - CompilerX64 Help

CONTROL SET CHECK

Set checkbox state

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET CHECK, CONTROL, SET, CHECK

Syntax

CONTROL SET CHECK [arguments]

Usage Examples

  1. CONTROL SET CHECK
  2. CONTROL SET CHECK argument1, argument2
  3. IF condition THEN CONTROL SET CHECK

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET COLOR - CompilerX64 Help

CONTROL SET COLOR

Set colors

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET COLOR, CONTROL, SET, COLOR

Syntax

CONTROL SET COLOR [arguments]

Usage Examples

  1. CONTROL SET COLOR
  2. CONTROL SET COLOR argument1, argument2
  3. IF condition THEN CONTROL SET COLOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET FOCUS - CompilerX64 Help

CONTROL SET FOCUS

Give keyboard focus

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET FOCUS, CONTROL, SET, FOCUS

Syntax

CONTROL SET FOCUS [arguments]

Usage Examples

  1. CONTROL SET FOCUS
  2. CONTROL SET FOCUS argument1, argument2
  3. IF condition THEN CONTROL SET FOCUS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET FONT - CompilerX64 Help

CONTROL SET FONT

Change font

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET FONT, CONTROL, SET, FONT

Syntax

CONTROL SET FONT [arguments]

Usage Examples

  1. CONTROL SET FONT
  2. CONTROL SET FONT argument1, argument2
  3. IF condition THEN CONTROL SET FONT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET IMAGE - CompilerX64 Help

CONTROL SET IMAGE

Set image display

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET IMAGE, CONTROL, SET, IMAGE

Syntax

CONTROL SET IMAGE [arguments]

Usage Examples

  1. CONTROL SET IMAGE
  2. CONTROL SET IMAGE argument1, argument2
  3. IF condition THEN CONTROL SET IMAGE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET LOC - CompilerX64 Help

CONTROL SET LOC

Move control position

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET LOC, CONTROL, SET, LOC

Syntax

CONTROL SET LOC [arguments]

Usage Examples

  1. CONTROL SET LOC
  2. CONTROL SET LOC argument1, argument2
  3. IF condition THEN CONTROL SET LOC

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET OPTION - CompilerX64 Help

CONTROL SET OPTION

Set option state

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET OPTION, CONTROL, SET, OPTION

Syntax

CONTROL SET OPTION [arguments]

Usage Examples

  1. CONTROL SET OPTION
  2. CONTROL SET OPTION argument1, argument2
  3. IF condition THEN CONTROL SET OPTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET SIZE - CompilerX64 Help

CONTROL SET SIZE

Resize control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET SIZE, CONTROL, SET, SIZE

Syntax

CONTROL SET SIZE [arguments]

Usage Examples

  1. CONTROL SET SIZE
  2. CONTROL SET SIZE argument1, argument2
  3. IF condition THEN CONTROL SET SIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET TEXT - CompilerX64 Help

CONTROL SET TEXT

Change text content

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET TEXT, CONTROL, SET, TEXT

Syntax

CONTROL SET TEXT [arguments]

Usage Examples

  1. CONTROL SET TEXT
  2. CONTROL SET TEXT argument1, argument2
  3. IF condition THEN CONTROL SET TEXT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SET USER - CompilerX64 Help

CONTROL SET USER

Set user data pointer

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SET USER, CONTROL, SET, USER

Syntax

CONTROL SET USER [arguments]

Usage Examples

  1. CONTROL SET USER
  2. CONTROL SET USER argument1, argument2
  3. IF condition THEN CONTROL SET USER

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONTROL SHOW STATE - CompilerX64 Help

CONTROL SHOW STATE

Show/hide control

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | CONTROL SHOW STATE, CONTROL, SHOW, STATE

Syntax

CONTROL SHOW STATE [arguments]

Usage Examples

  1. CONTROL SHOW STATE
  2. CONTROL SHOW STATE argument1, argument2
  3. IF condition THEN CONTROL SHOW STATE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


CONVERTING RC TO RES - CompilerX64 Help

CONVERTING RC TO RES

Convert resource files

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | CONVERTING RC TO RES, CONVERTING, RC, TO, RES

Syntax

CONVERTING RC TO RES [arguments]

Usage Examples

  1. CONVERTING RC TO RES
  2. CONVERTING RC TO RES argument1, argument2
  3. IF condition THEN CONVERTING RC TO RES

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DATA COUNT FUNCTION - CompilerX64 Help

DATA COUNT FUNCTION

Count array elements

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification |
Probe status |
F1 keywords | DATA COUNT FUNCTION, DATA COUNT, DATA, COUNT

Syntax

result = DATA COUNT FUNCTION(...)

Usage Examples

  1. DATA COUNT FUNCTION
  2. DATA COUNT FUNCTION argument1, argument2
  3. IF condition THEN DATA COUNT FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DATA STATEMENT - CompilerX64 Help

DATA STATEMENT

Define data section

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification |
Probe status |
F1 keywords | DATA STATEMENT, DATA

Syntax

DATA STATEMENT [arguments]

Usage Examples

  1. DATA STATEMENT
  2. DATA STATEMENT argument1, argument2
  3. IF condition THEN DATA STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DATACOUNT - CompilerX64 Help

DATACOUNT

Count DATA items

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | DATACOUNT

Syntax

result = DATACOUNT(...)

Usage Examples

  1. DATACOUNT
  2. DATACOUNT argument1, argument2
  3. IF condition THEN DATACOUNT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DATE SYSTEM VARIABLE - CompilerX64 Help

DATE SYSTEM VARIABLE

Current date/time variable

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DATE SYSTEM VARIABLE, DATE

Syntax

DATE SYSTEM VARIABLE [arguments]

Usage Examples

  1. DATE SYSTEM VARIABLE
  2. DATE SYSTEM VARIABLE argument1, argument2
  3. IF condition THEN DATE SYSTEM VARIABLE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DAYNAME$ FUNCTION - CompilerX64 Help

DAYNAME$ FUNCTION

Get day name string

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DAYNAME$ FUNCTION, DAYNAME$

Syntax

result = DAYNAME$ FUNCTION(...)

Usage Examples

  1. DAYNAME$ FUNCTION
  2. DAYNAME$ FUNCTION argument1, argument2
  3. IF condition THEN DAYNAME$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DECLARE FUNCTION - CompilerX64 Help

DECLARE FUNCTION

Declare external Windows API function

Kind | Function
Lane | PB-Interop
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_winapi_call.ps1; scripts/verify_interface_task_regression.ps1
Probe status |
F1 keywords | DECLARE FUNCTION, DECLARE

Syntax

DECLARE FUNCTION name LIB library [ALIAS alias] (parameters) AS type

Usage Examples

  1. DECLARE FUNCTION GetTickCount LIB "KERNEL32.DLL" ALIAS "GetTickCount" () AS DWORD
  2. DECLARE FUNCTION MessageBoxA LIB "USER32.DLL" ALIAS "MessageBoxA" (BYVAL hWnd AS DWORD, BYVAL lpText AS ASCIIZ PTR, BYVAL lpCaption AS ASCIIZ PTR, BYVAL uType AS DWORD) AS LONG
  3. Ticks = GetTickCount()

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; explicit external import call through linker import thunk
sub     rsp, 32
call    __imp_target_or_thunk
add     rsp, 32

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DECLARE SUB - CompilerX64 Help

DECLARE SUB

Declare external subroutine

Kind | Topic
Lane | PB-Interop
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_winapi_call.ps1; scripts/verify_interface_task_regression.ps1
Probe status |
F1 keywords | DECLARE SUB, DECLARE, SUB

Syntax

DECLARE SUB name LIB library [ALIAS alias] (parameters)

Usage Examples

  1. DECLARE SUB
  2. DECLARE SUB argument1, argument2
  3. IF condition THEN DECLARE SUB

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; explicit external import call through linker import thunk
sub     rsp, 32
call    __imp_target_or_thunk
add     rsp, 32

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DEFAULT VARIABLE TYPING - CompilerX64 Help

DEFAULT VARIABLE TYPING

Default type behavior

Kind | Datatype
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DEFAULT VARIABLE TYPING, DEFAULT, VARIABLE, TYPING

Syntax

DEFAULT VARIABLE TYPING [arguments]

Usage Examples

  1. DEFAULT VARIABLE TYPING
  2. DEFAULT VARIABLE TYPING argument1, argument2
  3. IF condition THEN DEFAULT VARIABLE TYPING

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DEFINING CONSTANTS - CompilerX64 Help

DEFINING CONSTANTS

Define named constants

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | DEFINING CONSTANTS, DEFINING, CONSTANTS

Syntax

DEFINING CONSTANTS [arguments]

Usage Examples

  1. DEFINING CONSTANTS
  2. DEFINING CONSTANTS argument1, argument2
  3. IF condition THEN DEFINING CONSTANTS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DEFINING USER-DEFINED TYPES - CompilerX64 Help

DEFINING USER-DEFINED TYPES

Define custom types (TYPE)

Kind | Datatype
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_udt_layout64.ps1; scripts/verify_runtime_udt_compat.ps1
Probe status |
F1 keywords | DEFINING USER-DEFINED TYPES, DEFINING, USER-DEFINED, TYPES

Syntax

DEFINING USER-DEFINED TYPES [arguments]

Usage Examples

  1. DEFINING USER-DEFINED TYPES
  2. DEFINING USER-DEFINED TYPES argument1, argument2
  3. IF condition THEN DEFINING USER-DEFINED TYPES

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DELAY - CompilerX64 Help

DELAY

Pause program execution

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification |
Probe status |
F1 keywords | DELAY

Syntax

DELAY [arguments]

Usage Examples

  1. DELAY
  2. DELAY argument1, argument2
  3. IF condition THEN DELAY

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DEPTH - CompilerX64 Help

DEPTH

Stack depth information

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DEPTH

Syntax

DEPTH [arguments]

Usage Examples

  1. DEPTH
  2. DEPTH argument1, argument2
  3. IF condition THEN DEPTH

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DESCRIBE - CompilerX64 Help

DESCRIBE

Describe object properties

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DESCRIBE

Syntax

DESCRIBE [arguments]

Usage Examples

  1. DESCRIBE
  2. DESCRIBE argument1, argument2
  3. IF condition THEN DESCRIBE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DESKTOP GET CLIENT - CompilerX64 Help

DESKTOP GET CLIENT

Get desktop client area

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DESKTOP GET CLIENT, DESKTOP, GET, CLIENT

Syntax

DESKTOP GET CLIENT [arguments]

Usage Examples

  1. DESKTOP GET CLIENT
  2. DESKTOP GET CLIENT argument1, argument2
  3. IF condition THEN DESKTOP GET CLIENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DESKTOP GET LOC - CompilerX64 Help

DESKTOP GET LOC

Get desktop location

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DESKTOP GET LOC, DESKTOP, GET, LOC

Syntax

DESKTOP GET LOC [arguments]

Usage Examples

  1. DESKTOP GET LOC
  2. DESKTOP GET LOC argument1, argument2
  3. IF condition THEN DESKTOP GET LOC

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DESKTOP GET PPI - CompilerX64 Help

DESKTOP GET PPI

Get pixels per inch

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DESKTOP GET PPI, DESKTOP, GET, PPI

Syntax

DESKTOP GET PPI [arguments]

Usage Examples

  1. DESKTOP GET PPI
  2. DESKTOP GET PPI argument1, argument2
  3. IF condition THEN DESKTOP GET PPI

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DESKTOP GET SIZE - CompilerX64 Help

DESKTOP GET SIZE

Get display size

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DESKTOP GET SIZE, DESKTOP, GET, SIZE

Syntax

DESKTOP GET SIZE [arguments]

Usage Examples

  1. DESKTOP GET SIZE
  2. DESKTOP GET SIZE argument1, argument2
  3. IF condition THEN DESKTOP GET SIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG DISABLE - CompilerX64 Help

DIALOG DISABLE

Disable dialog window

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG DISABLE, DIALOG, DISABLE

Syntax

DIALOG DISABLE [arguments]

Usage Examples

  1. DIALOG DISABLE
  2. DIALOG DISABLE argument1, argument2
  3. IF condition THEN DIALOG DISABLE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG DOEVENTS - CompilerX64 Help

DIALOG DOEVENTS

Process pending messages

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG DOEVENTS, DIALOG, DOEVENTS

Syntax

DIALOG DOEVENTS [arguments]

Usage Examples

  1. DIALOG DOEVENTS
  2. DIALOG DOEVENTS argument1, argument2
  3. IF condition THEN DIALOG DOEVENTS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG ENABLE - CompilerX64 Help

DIALOG ENABLE

Enable dialog window

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG ENABLE, DIALOG, ENABLE

Syntax

DIALOG ENABLE [arguments]

Usage Examples

  1. DIALOG ENABLE
  2. DIALOG ENABLE argument1, argument2
  3. IF condition THEN DIALOG ENABLE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG END - CompilerX64 Help

DIALOG END

Terminate dialog execution

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG END, DIALOG, END

Syntax

DIALOG END [arguments]

Usage Examples

  1. DIALOG END
  2. DIALOG END argument1, argument2
  3. IF condition THEN DIALOG END

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG FONT - CompilerX64 Help

DIALOG FONT

Set dialog font

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG FONT, DIALOG, FONT

Syntax

DIALOG FONT [arguments]

Usage Examples

  1. DIALOG FONT
  2. DIALOG FONT argument1, argument2
  3. IF condition THEN DIALOG FONT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG GET CLIENT - CompilerX64 Help

DIALOG GET CLIENT

Get client area info

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG GET CLIENT, DIALOG, GET, CLIENT

Syntax

DIALOG GET CLIENT [arguments]

Usage Examples

  1. DIALOG GET CLIENT
  2. DIALOG GET CLIENT argument1, argument2
  3. IF condition THEN DIALOG GET CLIENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG GET LOC - CompilerX64 Help

DIALOG GET LOC

Get position coordinates

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG GET LOC, DIALOG, GET, LOC

Syntax

DIALOG GET LOC [arguments]

Usage Examples

  1. DIALOG GET LOC
  2. DIALOG GET LOC argument1, argument2
  3. IF condition THEN DIALOG GET LOC

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG GET SIZE - CompilerX64 Help

DIALOG GET SIZE

Get dimensions

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG GET SIZE, DIALOG, GET, SIZE

Syntax

DIALOG GET SIZE [arguments]

Usage Examples

  1. DIALOG GET SIZE
  2. DIALOG GET SIZE argument1, argument2
  3. IF condition THEN DIALOG GET SIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG GET TEXT - CompilerX64 Help

DIALOG GET TEXT

Get window title/text

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG GET TEXT, DIALOG, GET, TEXT

Syntax

DIALOG GET TEXT [arguments]

Usage Examples

  1. DIALOG GET TEXT
  2. DIALOG GET TEXT argument1, argument2
  3. IF condition THEN DIALOG GET TEXT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG GET USER - CompilerX64 Help

DIALOG GET USER

Get user data pointer

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG GET USER, DIALOG, GET, USER

Syntax

DIALOG GET USER [arguments]

Usage Examples

  1. DIALOG GET USER
  2. DIALOG GET USER argument1, argument2
  3. IF condition THEN DIALOG GET USER

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG HIDE - CompilerX64 Help

DIALOG HIDE

Hide dialog from view

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG HIDE, DIALOG, HIDE

Syntax

DIALOG HIDE [arguments]

Usage Examples

  1. DIALOG HIDE
  2. DIALOG HIDE argument1, argument2
  3. IF condition THEN DIALOG HIDE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG MAXIMIZE - CompilerX64 Help

DIALOG MAXIMIZE

Maximize dialog window

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG MAXIMIZE, DIALOG, MAXIMIZE

Syntax

DIALOG MAXIMIZE [arguments]

Usage Examples

  1. DIALOG MAXIMIZE
  2. DIALOG MAXIMIZE argument1, argument2
  3. IF condition THEN DIALOG MAXIMIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG MINIMIZE - CompilerX64 Help

DIALOG MINIMIZE

Minimize dialog window

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG MINIMIZE, DIALOG, MINIMIZE

Syntax

DIALOG MINIMIZE [arguments]

Usage Examples

  1. DIALOG MINIMIZE
  2. DIALOG MINIMIZE argument1, argument2
  3. IF condition THEN DIALOG MINIMIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG NEW - CompilerX64 Help

DIALOG NEW

Create new dialog window

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG NEW, DIALOG, NEW

Syntax

DIALOG NEW [arguments]

Usage Examples

  1. DIALOG NEW
  2. DIALOG NEW argument1, argument2
  3. IF condition THEN DIALOG NEW

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG NONSTABLE - CompilerX64 Help

DIALOG NONSTABLE

Non-stable dialog behavior

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG NONSTABLE, DIALOG, NONSTABLE

Syntax

DIALOG NONSTABLE [arguments]

Usage Examples

  1. DIALOG NONSTABLE
  2. DIALOG NONSTABLE argument1, argument2
  3. IF condition THEN DIALOG NONSTABLE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG NORMALIZE - CompilerX64 Help

DIALOG NORMALIZE

Normalize coordinates

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG NORMALIZE, DIALOG, NORMALIZE

Syntax

DIALOG NORMALIZE [arguments]

Usage Examples

  1. DIALOG NORMALIZE
  2. DIALOG NORMALIZE argument1, argument2
  3. IF condition THEN DIALOG NORMALIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG PIXELS - CompilerX64 Help

DIALOG PIXELS

Convert to pixel units

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG PIXELS, DIALOG, PIXELS

Syntax

DIALOG PIXELS [arguments]

Usage Examples

  1. DIALOG PIXELS
  2. DIALOG PIXELS argument1, argument2
  3. IF condition THEN DIALOG PIXELS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG POST - CompilerX64 Help

DIALOG POST

Post message to dialog

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG POST, DIALOG, POST

Syntax

DIALOG POST [arguments]

Usage Examples

  1. DIALOG POST
  2. DIALOG POST argument1, argument2
  3. IF condition THEN DIALOG POST

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG REDRAW - CompilerX64 Help

DIALOG REDRAW

Force redraw of dialog

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG REDRAW, DIALOG, REDRAW

Syntax

DIALOG REDRAW [arguments]

Usage Examples

  1. DIALOG REDRAW
  2. DIALOG REDRAW argument1, argument2
  3. IF condition THEN DIALOG REDRAW

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SEND - CompilerX64 Help

DIALOG SEND

Send message to dialog

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SEND, DIALOG, SEND

Syntax

DIALOG SEND [arguments]

Usage Examples

  1. DIALOG SEND
  2. DIALOG SEND argument1, argument2
  3. IF condition THEN DIALOG SEND

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SET CLIENT - CompilerX64 Help

DIALOG SET CLIENT

Set client area info

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SET CLIENT, DIALOG, SET, CLIENT

Syntax

DIALOG SET CLIENT [arguments]

Usage Examples

  1. DIALOG SET CLIENT
  2. DIALOG SET CLIENT argument1, argument2
  3. IF condition THEN DIALOG SET CLIENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SET COLOR - CompilerX64 Help

DIALOG SET COLOR

Set colors

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SET COLOR, DIALOG, SET, COLOR

Syntax

DIALOG SET COLOR [arguments]

Usage Examples

  1. DIALOG SET COLOR
  2. DIALOG SET COLOR argument1, argument2
  3. IF condition THEN DIALOG SET COLOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SET ICON - CompilerX64 Help

DIALOG SET ICON

Set window icon

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SET ICON, DIALOG, SET, ICON

Syntax

DIALOG SET ICON [arguments]

Usage Examples

  1. DIALOG SET ICON
  2. DIALOG SET ICON argument1, argument2
  3. IF condition THEN DIALOG SET ICON

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SET LOC - CompilerX64 Help

DIALOG SET LOC

Move dialog position

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SET LOC, DIALOG, SET, LOC

Syntax

DIALOG SET LOC [arguments]

Usage Examples

  1. DIALOG SET LOC
  2. DIALOG SET LOC argument1, argument2
  3. IF condition THEN DIALOG SET LOC

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SET SIZE - CompilerX64 Help

DIALOG SET SIZE

Resize dialog

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SET SIZE, DIALOG, SET, SIZE

Syntax

DIALOG SET SIZE [arguments]

Usage Examples

  1. DIALOG SET SIZE
  2. DIALOG SET SIZE argument1, argument2
  3. IF condition THEN DIALOG SET SIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SET TEXT - CompilerX64 Help

DIALOG SET TEXT

Change title/text

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SET TEXT, DIALOG, SET, TEXT

Syntax

DIALOG SET TEXT [arguments]

Usage Examples

  1. DIALOG SET TEXT
  2. DIALOG SET TEXT argument1, argument2
  3. IF condition THEN DIALOG SET TEXT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SET USER - CompilerX64 Help

DIALOG SET USER

Set user data pointer

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SET USER, DIALOG, SET, USER

Syntax

DIALOG SET USER [arguments]

Usage Examples

  1. DIALOG SET USER
  2. DIALOG SET USER argument1, argument2
  3. IF condition THEN DIALOG SET USER

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SHOW MODAL - CompilerX64 Help

DIALOG SHOW MODAL

Show modal dialog

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SHOW MODAL, DIALOG, SHOW, MODAL

Syntax

DIALOG SHOW MODAL [arguments]

Usage Examples

  1. DIALOG SHOW MODAL
  2. DIALOG SHOW MODAL argument1, argument2
  3. IF condition THEN DIALOG SHOW MODAL

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SHOW MODELESS - CompilerX64 Help

DIALOG SHOW MODELESS

Show modeless dialog

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SHOW MODELESS, DIALOG, SHOW, MODELESS

Syntax

DIALOG SHOW MODELESS [arguments]

Usage Examples

  1. DIALOG SHOW MODELESS
  2. DIALOG SHOW MODELESS argument1, argument2
  3. IF condition THEN DIALOG SHOW MODELESS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG SHOW STATE - CompilerX64 Help

DIALOG SHOW STATE

Get show state

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG SHOW STATE, DIALOG, SHOW, STATE

Syntax

DIALOG SHOW STATE [arguments]

Usage Examples

  1. DIALOG SHOW STATE
  2. DIALOG SHOW STATE argument1, argument2
  3. IF condition THEN DIALOG SHOW STATE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG STABILIZE - CompilerX64 Help

DIALOG STABILIZE

Stabilize dialog behavior

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG STABILIZE, DIALOG, STABILIZE

Syntax

DIALOG STABILIZE [arguments]

Usage Examples

  1. DIALOG STABILIZE
  2. DIALOG STABILIZE argument1, argument2
  3. IF condition THEN DIALOG STABILIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG UNITS - CompilerX64 Help

DIALOG UNITS

Convert to dialog units

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG UNITS, DIALOG, UNITS

Syntax

DIALOG UNITS [arguments]

Usage Examples

  1. DIALOG UNITS
  2. DIALOG UNITS argument1, argument2
  3. IF condition THEN DIALOG UNITS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIALOG XLAT - CompilerX64 Help

DIALOG XLAT

Translate coordinates

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DIALOG XLAT, DIALOG, XLAT

Syntax

DIALOG XLAT [arguments]

Usage Examples

  1. DIALOG XLAT
  2. DIALOG XLAT argument1, argument2
  3. IF condition THEN DIALOG XLAT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DIM STATEMENT - CompilerX64 Help

DIM STATEMENT

Declare variables and arrays

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1; scripts/verify_self_host.ps1
Probe status |
F1 keywords | DIM STATEMENT, DIM

Syntax

DIM variable [AS type]
DIM array(lower TO upper) AS type

Usage Examples

  1. DIM Count AS LONG
  2. DIM Names(1 TO 10) AS STRING
  3. DIM Buffer(0 TO 255) AS BYTE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; local scalar allocation in function frame
sub     rsp, 8
; variable lives at [rbp-8]
mov     qword ptr [rbp-8], 0

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DISPLAY BROWSE - CompilerX64 Help

DISPLAY BROWSE

Browse for files/folders

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DISPLAY BROWSE, DISPLAY, BROWSE

Syntax

DISPLAY BROWSE [arguments]

Usage Examples

  1. DISPLAY BROWSE
  2. DISPLAY BROWSE argument1, argument2
  3. IF condition THEN DISPLAY BROWSE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DISPLAY COLOR - CompilerX64 Help

DISPLAY COLOR

Display color picker

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DISPLAY COLOR, DISPLAY, COLOR

Syntax

DISPLAY COLOR [arguments]

Usage Examples

  1. DISPLAY COLOR
  2. DISPLAY COLOR argument1, argument2
  3. IF condition THEN DISPLAY COLOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DISPLAY FONT - CompilerX64 Help

DISPLAY FONT

Display font selector

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DISPLAY FONT, DISPLAY, FONT

Syntax

DISPLAY FONT [arguments]

Usage Examples

  1. DISPLAY FONT
  2. DISPLAY FONT argument1, argument2
  3. IF condition THEN DISPLAY FONT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DISPLAY OPENFILE - CompilerX64 Help

DISPLAY OPENFILE

Open file dialog

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DISPLAY OPENFILE, DISPLAY, OPENFILE

Syntax

DISPLAY OPENFILE [arguments]

Usage Examples

  1. DISPLAY OPENFILE
  2. DISPLAY OPENFILE argument1, argument2
  3. IF condition THEN DISPLAY OPENFILE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


DISPLAY SAVEFILE - CompilerX64 Help

DISPLAY SAVEFILE

Save file dialog

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | DISPLAY SAVEFILE, DISPLAY, SAVEFILE

Syntax

DISPLAY SAVEFILE [arguments]

Usage Examples

  1. DISPLAY SAVEFILE
  2. DISPLAY SAVEFILE argument1, argument2
  3. IF condition THEN DISPLAY SAVEFILE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ENUM - CompilerX64 Help

ENUM

Enumeration definition

Kind | Datatype
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | ENUM

Syntax

ENUM [arguments]

Usage Examples

  1. ENUM
  2. ENUM argument1, argument2
  3. IF condition THEN ENUM

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ENVIRON - CompilerX64 Help

ENVIRON

Set environment variable

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | ENVIRON

Syntax

ENVIRON [arguments]

Usage Examples

  1. ENVIRON
  2. ENVIRON argument1, argument2
  3. IF condition THEN ENVIRON

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


EOF FUNCTION - CompilerX64 Help

EOF FUNCTION

Test end-of-file condition

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | EOF FUNCTION, EOF

Syntax

result = EOF FUNCTION(...)

Usage Examples

  1. EOF FUNCTION
  2. EOF FUNCTION argument1, argument2
  3. IF condition THEN EOF FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERASE STATEMENT - CompilerX64 Help

ERASE STATEMENT

Reset or deallocate arrays

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_arraycore.ps1
Probe status |
F1 keywords | ERASE STATEMENT, ERASE

Syntax

ERASE array [, array ...]

Usage Examples

  1. ERASE STATEMENT
  2. ERASE STATEMENT argument1, argument2
  3. IF condition THEN ERASE STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERR$ FUNCTION - CompilerX64 Help

ERR$ FUNCTION

Get error message string

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERR$ FUNCTION, ERR$

Syntax

result = ERR$ FUNCTION(...)

Usage Examples

  1. ERR$ FUNCTION
  2. ERR$ FUNCTION argument1, argument2
  3. IF condition THEN ERR$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERRLINE FUNCTION - CompilerX64 Help

ERRLINE FUNCTION

Get error line number

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERRLINE FUNCTION, ERRLINE

Syntax

result = ERRLINE FUNCTION(...)

Usage Examples

  1. ERRLINE FUNCTION
  2. ERRLINE FUNCTION argument1, argument2
  3. IF condition THEN ERRLINE FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERRLINE$ FUNCTION - CompilerX64 Help

ERRLINE$ FUNCTION

Get error line text

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERRLINE$ FUNCTION, ERRLINE$

Syntax

result = ERRLINE$ FUNCTION(...)

Usage Examples

  1. ERRLINE$ FUNCTION
  2. ERRLINE$ FUNCTION argument1, argument2
  3. IF condition THEN ERRLINE$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERRNO FUNCTION - CompilerX64 Help

ERRNO FUNCTION

Get error number

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERRNO FUNCTION, ERRNO

Syntax

result = ERRNO FUNCTION(...)

Usage Examples

  1. ERRNO FUNCTION
  2. ERRNO FUNCTION argument1, argument2
  3. IF condition THEN ERRNO FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 0 - CompilerX64 Help

ERROR 0

No error condition

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 0, ERROR

Syntax

ERROR 0 [arguments]

Usage Examples

  1. ERROR 0
  2. ERROR 0 argument1, argument2
  3. IF condition THEN ERROR 0

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 11 - CompilerX64 Help

ERROR 11

Division by zero

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 11, ERROR, 11

Syntax

ERROR 11 [arguments]

Usage Examples

  1. ERROR 11
  2. ERROR 11 argument1, argument2
  3. IF condition THEN ERROR 11

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 24 - CompilerX64 Help

ERROR 24

Device timeout

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 24, ERROR, 24

Syntax

ERROR 24 [arguments]

Usage Examples

  1. ERROR 24
  2. ERROR 24 argument1, argument2
  3. IF condition THEN ERROR 24

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 241 - CompilerX64 Help

ERROR 241

Global memory corrupt

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 241, ERROR, 241

Syntax

ERROR 241 [arguments]

Usage Examples

  1. ERROR 241
  2. ERROR 241 argument1, argument2
  3. IF condition THEN ERROR 241

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 242 - CompilerX64 Help

ERROR 242

String space corrupt

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 242, ERROR, 242

Syntax

ERROR 242 [arguments]

Usage Examples

  1. ERROR 242
  2. ERROR 242 argument1, argument2
  3. IF condition THEN ERROR 242

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 401 - CompilerX64 Help

ERROR 401

Expression too long/complex

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 401, ERROR, 401

Syntax

ERROR 401 [arguments]

Usage Examples

  1. ERROR 401
  2. ERROR 401 argument1, argument2
  3. IF condition THEN ERROR 401

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 402 - CompilerX64 Help

ERROR 402

Statement too long/complex

Kind | Statement
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 402, ERROR, 402

Syntax

ERROR 402 [arguments]

Usage Examples

  1. ERROR 402
  2. ERROR 402 argument1, argument2
  3. IF condition THEN ERROR 402

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 403 - CompilerX64 Help

ERROR 403

IF nesting overflow

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 403, ERROR, 403

Syntax

ERROR 403 [arguments]

Usage Examples

  1. ERROR 403
  2. ERROR 403 argument1, argument2
  3. IF condition THEN ERROR 403

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 404 - CompilerX64 Help

ERROR 404

Include file macro nesting overflow

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 404, ERROR, 404

Syntax

ERROR 404 [arguments]

Usage Examples

  1. ERROR 404
  2. ERROR 404 argument1, argument2
  3. IF condition THEN ERROR 404

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 405 - CompilerX64 Help

ERROR 405

Block nesting overflow

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 405, ERROR, 405

Syntax

ERROR 405 [arguments]

Usage Examples

  1. ERROR 405
  2. ERROR 405 argument1, argument2
  3. IF condition THEN ERROR 405

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 406 - CompilerX64 Help

ERROR 406

Compiler out of memory

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 406, ERROR, 406

Syntax

ERROR 406 [arguments]

Usage Examples

  1. ERROR 406
  2. ERROR 406 argument1, argument2
  3. IF condition THEN ERROR 406

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 407 - CompilerX64 Help

ERROR 407

Source line too long

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 407, ERROR, 407

Syntax

ERROR 407 [arguments]

Usage Examples

  1. ERROR 407
  2. ERROR 407 argument1, argument2
  3. IF condition THEN ERROR 407

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 408 - CompilerX64 Help

ERROR 408

Wrong compiler for program

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 408, ERROR, 408

Syntax

ERROR 408 [arguments]

Usage Examples

  1. ERROR 408
  2. ERROR 408 argument1, argument2
  3. IF condition THEN ERROR 408

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 409 - CompilerX64 Help

ERROR 409

Sub/function/method too large

Kind | Function
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 409, ERROR, 409

Syntax

result = ERROR 409(...)

Usage Examples

  1. ERROR 409
  2. ERROR 409 argument1, argument2
  3. IF condition THEN ERROR 409

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 411-417 - CompilerX64 Help

ERROR 411-417

Various expected errors

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERROR 411-417, ERROR, 411-417

Syntax

ERROR 411-417 [arguments]

Usage Examples

  1. ERROR 411-417
  2. ERROR 411-417 argument1, argument2
  3. IF condition THEN ERROR 411-417

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 418 - CompilerX64 Help

ERROR 418

Statement expected

Kind | Statement
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 418, ERROR, 418

Syntax

ERROR 418 [arguments]

Usage Examples

  1. ERROR 418
  2. ERROR 418 argument1, argument2
  3. IF condition THEN ERROR 418

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 419 - CompilerX64 Help

ERROR 419

Label/line number expected

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 419, ERROR, 419

Syntax

ERROR 419 [arguments]

Usage Examples

  1. ERROR 419
  2. ERROR 419 argument1, argument2
  3. IF condition THEN ERROR 419

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 420 - CompilerX64 Help

ERROR 420

Relational operator expected

Kind | Operator
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 420, ERROR, 420

Syntax

result = left_operand ERROR 420 right_operand

Usage Examples

  1. ERROR 420
  2. ERROR 420 argument1, argument2
  3. IF condition THEN ERROR 420

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 421 - CompilerX64 Help

ERROR 421

String operand expected

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 421, ERROR, 421

Syntax

ERROR 421 [arguments]

Usage Examples

  1. ERROR 421
  2. ERROR 421 argument1, argument2
  3. IF condition THEN ERROR 421

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 422-426 - CompilerX64 Help

ERROR 422-426

Variable type expected errors

Kind | Datatype
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERROR 422-426, ERROR, 422-426

Syntax

ERROR 422-426 [arguments]

Usage Examples

  1. ERROR 422-426
  2. ERROR 422-426 argument1, argument2
  3. IF condition THEN ERROR 422-426

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 427-429 - CompilerX64 Help

ERROR 427-429

Constant type expected errors

Kind | Datatype
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERROR 427-429, ERROR, 427-429

Syntax

ERROR 427-429 [arguments]

Usage Examples

  1. ERROR 427-429
  2. ERROR 427-429 argument1, argument2
  3. IF condition THEN ERROR 427-429

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 430-433 - CompilerX64 Help

ERROR 430-433

Numeric variable expected errors

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERROR 430-433, ERROR, 430-433

Syntax

ERROR 430-433 [arguments]

Usage Examples

  1. ERROR 430-433
  2. ERROR 430-433 argument1, argument2
  3. IF condition THEN ERROR 430-433

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 434-458 - CompilerX64 Help

ERROR 434-458

Syntax element expected errors

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERROR 434-458, ERROR, 434-458

Syntax

ERROR 434-458 [arguments]

Usage Examples

  1. ERROR 434-458
  2. ERROR 434-458 argument1, argument2
  3. IF condition THEN ERROR 434-458

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 459 - CompilerX64 Help

ERROR 459

NEXT expected (FOR loop)

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | ERROR 459, ERROR, 459

Syntax

ERROR 459 [arguments]

Usage Examples

  1. ERROR 459
  2. ERROR 459 argument1, argument2
  3. IF condition THEN ERROR 459

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ERROR 460+ - CompilerX64 Help

ERROR 460+

Various undefined/reference errors

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ERROR 460+, ERROR, 460+

Syntax

ERROR 460+ [arguments]

Usage Examples

  1. ERROR 460+
  2. ERROR 460+ argument1, argument2
  3. IF condition THEN ERROR 460+

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


EXIT DO - CompilerX64 Help

EXIT DO

Exit DO loop early

Kind | Topic
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_exit_iterate.ps1; scripts/verify_do_loop.ps1
Probe status |
F1 keywords | EXIT DO, EXIT, DO

Syntax

EXIT DO

Usage Examples

  1. EXIT DO
  2. EXIT DO argument1, argument2
  3. IF condition THEN EXIT DO

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


EXIT FOR - CompilerX64 Help

EXIT FOR

Exit FROM loop early

Kind | Topic
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_exit_iterate.ps1
Probe status |
F1 keywords | EXIT FOR, EXIT

Syntax

EXIT FOR

Usage Examples

  1. EXIT FOR
  2. EXIT FOR argument1, argument2
  3. IF condition THEN EXIT FOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


EXIT PROGRAM - CompilerX64 Help

EXIT PROGRAM

Exit program with code

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | EXIT PROGRAM, EXIT, PROGRAM

Syntax

EXIT PROGRAM

Usage Examples

  1. EXIT PROGRAM
  2. EXIT PROGRAM argument1, argument2
  3. IF condition THEN EXIT PROGRAM

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


EXIT SELECT - CompilerX64 Help

EXIT SELECT

Exit SELECT CASE early

Kind | Topic
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_select_case.ps1
Probe status |
F1 keywords | EXIT SELECT, EXIT, SELECT

Syntax

EXIT SELECT

Usage Examples

  1. EXIT SELECT
  2. EXIT SELECT argument1, argument2
  3. IF condition THEN EXIT SELECT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


EXIT SUB/EXIT FUNCTION - CompilerX64 Help

EXIT SUB/EXIT FUNCTION

Exit subroutine/function

Kind | Function
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_exit_iterate.ps1; scripts/verify_stage_exit_core.ps1
Probe status |
F1 keywords | EXIT SUB/EXIT FUNCTION, EXIT SUB/EXIT, EXIT, SUB

Syntax

EXIT SUB/EXIT FUNCTION

Usage Examples

  1. EXIT SUB/EXIT FUNCTION
  2. EXIT SUB/EXIT FUNCTION argument1, argument2
  3. IF condition THEN EXIT SUB/EXIT FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


FIELD - CompilerX64 Help

FIELD

Define random file fields

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_iocore.ps1
Probe status |
F1 keywords | FIELD

Syntax

FIELD [arguments]

Usage Examples

  1. FIELD
  2. FIELD argument1, argument2
  3. IF condition THEN FIELD

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


FILE ATTRIBS FUNCTION - CompilerX64 Help

FILE ATTRIBS FUNCTION

Get file attributes

Kind | Function
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | FILE ATTRIBS FUNCTION, FILE ATTRIBS, FILE, ATTRIBS

Syntax

result = FILE ATTRIBS FUNCTION(...)

Usage Examples

  1. FILE ATTRIBS FUNCTION
  2. FILE ATTRIBS FUNCTION argument1, argument2
  3. IF condition THEN FILE ATTRIBS FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


FILE ATTRIBUTES - CompilerX64 Help

FILE ATTRIBUTES

File attribute flags

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | FILE ATTRIBUTES, FILE, ATTRIBUTES

Syntax

FILE ATTRIBUTES [arguments]

Usage Examples

  1. FILE ATTRIBUTES
  2. FILE ATTRIBUTES argument1, argument2
  3. IF condition THEN FILE ATTRIBUTES

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


FILE EXIST - CompilerX64 Help

FILE EXIST

Check if file exists (FileExists)

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | FILE EXIST, FILE, EXIST

Syntax

FILE EXIST [arguments]

Usage Examples

  1. FILE EXIST
  2. FILE EXIST argument1, argument2
  3. IF condition THEN FILE EXIST

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


FILECOPY - CompilerX64 Help

FILECOPY

Copy file

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | FILECOPY

Syntax

FILECOPY [arguments]

Usage Examples

  1. FILECOPY
  2. FILECOPY argument1, argument2
  3. IF condition THEN FILECOPY

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


FILES - CompilerX64 Help

FILES

List files in directory (alternative)

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification |
Probe status |
F1 keywords | FILES

Syntax

FILES [arguments]

Usage Examples

  1. FILES
  2. FILES argument1, argument2
  3. IF condition THEN FILES

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


FIND TEXT - CompilerX64 Help

FIND TEXT

Search text in file

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | FIND TEXT, FIND, TEXT

Syntax

FIND TEXT [arguments]

Usage Examples

  1. FIND TEXT
  2. FIND TEXT argument1, argument2
  3. IF condition THEN FIND TEXT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


FLOATING POINT TYPES - CompilerX64 Help

FLOATING POINT TYPES

Floating point data types

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_expression_semantics.ps1
Probe status |
F1 keywords | FLOATING POINT TYPES, FLOATING, POINT, TYPES

Syntax

FLOATING POINT TYPES [arguments]

Usage Examples

  1. FLOATING POINT TYPES
  2. FLOATING POINT TYPES argument1, argument2
  3. IF condition THEN FLOATING POINT TYPES

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


GET - CompilerX64 Help

GET

Read from random/binary file

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_iocore.ps1
Probe status |
F1 keywords | GET

Syntax

GET [arguments]

Usage Examples

  1. GET
  2. GET argument1, argument2
  3. IF condition THEN GET

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


GET$ - CompilerX64 Help

GET$

Get string from file

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_iocore.ps1
Probe status |
F1 keywords | GET$

Syntax

GET$ [arguments]

Usage Examples

  1. GET$
  2. GET$ argument1, argument2
  3. IF condition THEN GET$

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


GLOBAL - CompilerX64 Help

GLOBAL

Global variable declaration

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1; scripts/test_compile.ps1
Probe status | PASS
F1 keywords | GLOBAL

Syntax

GLOBAL variable [AS type]

Usage Examples

  1. GLOBAL
  2. GLOBAL argument1, argument2
  3. IF condition THEN GLOBAL

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; local scalar allocation in function frame
sub     rsp, 8
; variable lives at [rbp-8]
mov     qword ptr [rbp-8], 0

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


GOSUB - CompilerX64 Help

GOSUB

Subroutine call

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_gosub_return_runtime.ps1
Probe status | PASS
F1 keywords | GOSUB

Syntax

GOSUB label
...
label:
    statements
RETURN

Usage Examples

  1. GOSUB
  2. GOSUB argument1, argument2
  3. IF condition THEN GOSUB

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


GOTO - CompilerX64 Help

GOTO

Unconditional branch

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_goto_routine_exit.ps1
Probe status |
F1 keywords | GOTO

Syntax

GOTO [arguments]

Usage Examples

  1. GOTO
  2. GOTO argument1, argument2
  3. IF condition THEN GOTO

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


GOTO BOOKMARK - CompilerX64 Help

GOTO BOOKMARK

Jump to bookmark

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | GOTO BOOKMARK, GOTO, BOOKMARK

Syntax

GOTO BOOKMARK [arguments]

Usage Examples

  1. GOTO BOOKMARK
  2. GOTO BOOKMARK argument1, argument2
  3. IF condition THEN GOTO BOOKMARK

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


GOTO LINE - CompilerX64 Help

GOTO LINE

Go to specific line number

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | GOTO LINE, GOTO, LINE

Syntax

GOTO LINE [arguments]

Usage Examples

  1. GOTO LINE
  2. GOTO LINE argument1, argument2
  3. IF condition THEN GOTO LINE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


GOTO LINE DIALOG - CompilerX64 Help

GOTO LINE DIALOG

Line goto dialog

Kind | Family
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | GOTO LINE DIALOG, GOTO, LINE, DIALOG

Syntax

GOTO LINE DIALOG [arguments]

Usage Examples

  1. GOTO LINE DIALOG
  2. GOTO LINE DIALOG argument1, argument2
  3. IF condition THEN GOTO LINE DIALOG

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


GOTOBUTTON - CompilerX64 Help

GOTOBUTTON

Button navigation (DDT)

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | GOTOBUTTON

Syntax

GOTOBUTTON [arguments]

Usage Examples

  1. GOTOBUTTON
  2. GOTOBUTTON argument1, argument2
  3. IF condition THEN GOTOBUTTON

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


HELP - CompilerX64 Help

HELP

Display help system

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | HELP

Syntax

HELP [arguments]

Usage Examples

  1. HELP
  2. HELP argument1, argument2
  3. IF condition THEN HELP

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


HEX$ FUNCTION - CompilerX64 Help

HEX$ FUNCTION

Convert to hexadecimal string

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | HEX$ FUNCTION, HEX$

Syntax

result = HEX$ FUNCTION(...)

Usage Examples

  1. HEX$ FUNCTION
  2. HEX$ FUNCTION argument1, argument2
  3. IF condition THEN HEX$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


IF THEN ELSE - CompilerX64 Help

IF THEN ELSE

Conditional execution statement

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_if_else_chain.ps1; scripts/verify_interface_task_regression.ps1
Probe status |
F1 keywords | IF THEN ELSE, IF, THEN, ELSE

Syntax

IF condition THEN statement [ELSE statement]
IF condition THEN
    statements
[ELSEIF condition THEN]
    statements
[ELSE]
    statements
END IF

Usage Examples

  1. IF Count > 0 THEN PRINT "ready" ELSE PRINT "empty"
  2. IF Total > Limit THEN
    PRINT "over limit"
ELSE
    PRINT "inside limit"
END IF
  3. IF A = 1 THEN B = 10 ELSEIF A = 2 THEN B = 20 ELSE B = 0

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; IF condition THEN ... ELSE ...
cmp     rax, 0
je      .else_block
; then block
jmp     .end_if
.else_block:
; else block
.end_if:

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


IN OPERATOR - CompilerX64 Help

IN OPERATOR

Check if in collection

Kind | Operator
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | IN OPERATOR, IN

Syntax

result = left_operand IN right_operand

Usage Examples

  1. IN OPERATOR
  2. IN OPERATOR argument1, argument2
  3. IF condition THEN IN OPERATOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


INCR / DECR - CompilerX64 Help

INCR / DECR

Increment/decrement variable

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_expression_semantics.ps1
Probe status |
F1 keywords | INCR / DECR, INCR, DECR

Syntax

INCR / DECR [arguments]

Usage Examples

  1. INCR / DECR
  2. INCR / DECR argument1, argument2
  3. IF condition THEN INCR / DECR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


INPUT # STATEMENT - CompilerX64 Help

INPUT # STATEMENT

Read from sequential file

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_iocore.ps1
Probe status |
F1 keywords | INPUT # STATEMENT, INPUT #, INPUT

Syntax

INPUT # STATEMENT [arguments]

Usage Examples

  1. INPUT # STATEMENT
  2. INPUT # STATEMENT argument1, argument2
  3. IF condition THEN INPUT # STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; runtime I/O helper call
lea     rcx, [file_descriptor]
call    cx64_file_io_helper
; status/result in rax

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


INSERT ITEM - CompilerX64 Help

INSERT ITEM

Insert into listbox/combo

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | INSERT ITEM, INSERT, ITEM

Syntax

INSERT ITEM [arguments]

Usage Examples

  1. INSERT ITEM
  2. INSERT ITEM argument1, argument2
  3. IF condition THEN INSERT ITEM

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


INSTR FUNCTION - CompilerX64 Help

INSTR FUNCTION

Find substring position

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | INSTR FUNCTION, INSTR

Syntax

result = INSTR FUNCTION(...)

Usage Examples

  1. INSTR FUNCTION
  2. INSTR FUNCTION argument1, argument2
  3. IF condition THEN INSTR FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ITERATE - CompilerX64 Help

ITERATE

Continue loop iteration

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_exit_iterate.ps1
Probe status | PASS
F1 keywords | ITERATE

Syntax

ITERATE [arguments]

Usage Examples

  1. ITERATE
  2. ITERATE argument1, argument2
  3. IF condition THEN ITERATE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


JPEG IMAGE DISPLAY - CompilerX64 Help

JPEG IMAGE DISPLAY

Display JPEG images

Kind | Family
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | JPEG IMAGE DISPLAY, JPEG, IMAGE, DISPLAY

Syntax

JPEG IMAGE DISPLAY [arguments]

Usage Examples

  1. JPEG IMAGE DISPLAY
  2. JPEG IMAGE DISPLAY argument1, argument2
  3. IF condition THEN JPEG IMAGE DISPLAY

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


KERNEL FUNCTIONS - CompilerX64 Help

KERNEL FUNCTIONS

Windows kernel functions (API)

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | KERNEL FUNCTIONS, KERNEL, FUNCTIONS

Syntax

KERNEL FUNCTIONS [arguments]

Usage Examples

  1. KERNEL FUNCTIONS
  2. KERNEL FUNCTIONS argument1, argument2
  3. IF condition THEN KERNEL FUNCTIONS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


KEYBOARD STATE - CompilerX64 Help

KEYBOARD STATE

Check keyboard state

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | KEYBOARD STATE, KEYBOARD, STATE

Syntax

KEYBOARD STATE [arguments]

Usage Examples

  1. KEYBOARD STATE
  2. KEYBOARD STATE argument1, argument2
  3. IF condition THEN KEYBOARD STATE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


KILL - CompilerX64 Help

KILL

Delete file from disk

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification |
Probe status |
F1 keywords | KILL

Syntax

KILL [arguments]

Usage Examples

  1. KILL
  2. KILL argument1, argument2
  3. IF condition THEN KILL

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LCASE$ FUNCTION - CompilerX64 Help

LCASE$ FUNCTION

Convert to lowercase

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | LCASE$ FUNCTION, LCASE$

Syntax

result = LCASE$ FUNCTION(...)

Usage Examples

  1. LCASE$ FUNCTION
  2. LCASE$ FUNCTION argument1, argument2
  3. IF condition THEN LCASE$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LEFT$ FUNCTION - CompilerX64 Help

LEFT$ FUNCTION

Extract leftmost characters

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | LEFT$ FUNCTION, LEFT$

Syntax

result$ = LEFT$(string_expression, count)

Usage Examples

  1. LEFT$ FUNCTION
  2. LEFT$ FUNCTION argument1, argument2
  3. IF condition THEN LEFT$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LEN FUNCTION - CompilerX64 Help

LEN FUNCTION

Get string length

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_string64.ps1
Probe status |
F1 keywords | LEN FUNCTION, LEN

Syntax

result = LEN(expression)

Usage Examples

  1. N = LEN("abc")
  2. N = LEN(Buffer$)
  3. IF LEN(Name$) = 0 THEN PRINT "missing"

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; string length helper path
mov     rcx, [string_descriptor]
call    cx64_string_len
; result in rax

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LINE - CompilerX64 Help

LINE

Draw line on graphics output

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | LINE

Syntax

LINE [arguments]

Usage Examples

  1. LINE
  2. LINE argument1, argument2
  3. IF condition THEN LINE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LINE INPUT # STATEMENT - CompilerX64 Help

LINE INPUT # STATEMENT

Read entire line from file

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_iocore.ps1
Probe status |
F1 keywords | LINE INPUT # STATEMENT, LINE INPUT #, LINE, INPUT

Syntax

LINE INPUT # STATEMENT [arguments]

Usage Examples

  1. LINE INPUT # STATEMENT
  2. LINE INPUT # STATEMENT argument1, argument2
  3. IF condition THEN LINE INPUT # STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; runtime I/O helper call
lea     rcx, [file_descriptor]
call    cx64_file_io_helper
; status/result in rax

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LISTBOX ADD ITEM - CompilerX64 Help

LISTBOX ADD ITEM

Add item to listbox

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | LISTBOX ADD ITEM, LISTBOX, ADD, ITEM

Syntax

LISTBOX ADD ITEM [arguments]

Usage Examples

  1. LISTBOX ADD ITEM
  2. LISTBOX ADD ITEM argument1, argument2
  3. IF condition THEN LISTBOX ADD ITEM

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LISTBOX DELETE ITEM - CompilerX64 Help

LISTBOX DELETE ITEM

Delete item from listbox

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | LISTBOX DELETE ITEM, LISTBOX, DELETE, ITEM

Syntax

LISTBOX DELETE ITEM [arguments]

Usage Examples

  1. LISTBOX DELETE ITEM
  2. LISTBOX DELETE ITEM argument1, argument2
  3. IF condition THEN LISTBOX DELETE ITEM

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LISTBOX SELECT - CompilerX64 Help

LISTBOX SELECT

Select item in listbox

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | LISTBOX SELECT, LISTBOX, SELECT

Syntax

LISTBOX SELECT [arguments]

Usage Examples

  1. LISTBOX SELECT
  2. LISTBOX SELECT argument1, argument2
  3. IF condition THEN LISTBOX SELECT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LOCAL - CompilerX64 Help

LOCAL

Local variable declaration

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1; scripts/verify_self_host.ps1
Probe status | PASS
F1 keywords | LOCAL

Syntax

LOCAL variable [AS type]

Usage Examples

  1. LOCAL
  2. LOCAL argument1, argument2
  3. IF condition THEN LOCAL

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; local scalar allocation in function frame
sub     rsp, 8
; variable lives at [rbp-8]
mov     qword ptr [rbp-8], 0

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


LOCK - CompilerX64 Help

LOCK

Lock file region

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_file_openclose.ps1
Probe status |
F1 keywords | LOCK

Syntax

LOCK [arguments]

Usage Examples

  1. LOCK
  2. LOCK argument1, argument2
  3. IF condition THEN LOCK

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


MAT - CompilerX64 Help

MAT

Matrix operations

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_arraycore.ps1
Probe status |
F1 keywords | MAT

Syntax

MAT [arguments]

Usage Examples

  1. MAT
  2. MAT argument1, argument2
  3. IF condition THEN MAT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


MAXIMIZE WINDOW - CompilerX64 Help

MAXIMIZE WINDOW

Maximize window (alternative)

Kind | Topic
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | MAXIMIZE WINDOW, MAXIMIZE, WINDOW

Syntax

MAXIMIZE WINDOW [arguments]

Usage Examples

  1. MAXIMIZE WINDOW
  2. MAXIMIZE WINDOW argument1, argument2
  3. IF condition THEN MAXIMIZE WINDOW

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


MID$ FUNCTION - CompilerX64 Help

MID$ FUNCTION

Extract substring

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | MID$ FUNCTION, MID$

Syntax

result$ = MID$(string_expression, start [, count])

Usage Examples

  1. MID$ FUNCTION
  2. MID$ FUNCTION argument1, argument2
  3. IF condition THEN MID$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


MINIMIZE WINDOW - CompilerX64 Help

MINIMIZE WINDOW

Minimize window (alternative)

Kind | Topic
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | MINIMIZE WINDOW, MINIMIZE, WINDOW

Syntax

MINIMIZE WINDOW [arguments]

Usage Examples

  1. MINIMIZE WINDOW
  2. MINIMIZE WINDOW argument1, argument2
  3. IF condition THEN MINIMIZE WINDOW

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


MKDIR STATEMENT - CompilerX64 Help

MKDIR STATEMENT

Create directory

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | MKDIR STATEMENT, MKDIR

Syntax

MKDIR STATEMENT [arguments]

Usage Examples

  1. MKDIR STATEMENT
  2. MKDIR STATEMENT argument1, argument2
  3. IF condition THEN MKDIR STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


MODULE - CompilerX64 Help

MODULE

Define module/section

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_module_interface_impl.ps1
Probe status |
F1 keywords | MODULE

Syntax

MODULE [arguments]

Usage Examples

  1. MODULE
  2. MODULE argument1, argument2
  3. IF condition THEN MODULE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


MSGBOX - CompilerX64 Help

MSGBOX

Message box dialog

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | MSGBOX

Syntax

MSGBOX [arguments]

Usage Examples

  1. MSGBOX
  2. MSGBOX argument1, argument2
  3. IF condition THEN MSGBOX

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


NEXT STATEMENT - CompilerX64 Help

NEXT STATEMENT

FOR loop counter increment

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_exit_iterate.ps1
Probe status |
F1 keywords | NEXT STATEMENT, NEXT

Syntax

FOR counter = start TO finish [STEP increment]
    statements
NEXT [counter]

Usage Examples

  1. FOR I = 1 TO 10
    PRINT I
NEXT I
  2. FOR I = 10 TO 1 STEP -1
    PRINT I
NEXT
  3. FOR I = 1 TO 100
    IF I = 5 THEN EXIT FOR
NEXT I

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; FOR counter loop
mov     qword ptr [counter], 1
.loop_start:
cmp     qword ptr [counter], 10
jg      .loop_end
; loop body
inc     qword ptr [counter]
jmp     .loop_start
.loop_end:

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


NOT OPERATOR - CompilerX64 Help

NOT OPERATOR

Logical negation operator

Kind | Operator
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_expression_semantics.ps1
Probe status |
F1 keywords | NOT OPERATOR, NOT

Syntax

result = left_operand NOT right_operand

Usage Examples

  1. NOT OPERATOR
  2. NOT OPERATOR argument1, argument2
  3. IF condition THEN NOT OPERATOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ON ERROR GOTO - CompilerX64 Help

ON ERROR GOTO

Error handling handler

Kind | Topic
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | tests/TE_PB_Core_Blockers_Codex.bas
Probe status |
F1 keywords | ON ERROR GOTO, ON, ERROR, GOTO

Syntax

ON ERROR GOTO [arguments]

Usage Examples

  1. ON ERROR GOTO
  2. ON ERROR GOTO argument1, argument2
  3. IF condition THEN ON ERROR GOTO

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ON KEY DOWN - CompilerX64 Help

ON KEY DOWN

Keyboard event handling

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ON KEY DOWN, ON, KEY, DOWN

Syntax

ON KEY DOWN [arguments]

Usage Examples

  1. ON KEY DOWN
  2. ON KEY DOWN argument1, argument2
  3. IF condition THEN ON KEY DOWN

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ON KEY UP - CompilerX64 Help

ON KEY UP

Keyboard event handling

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ON KEY UP, ON, KEY, UP

Syntax

ON KEY UP [arguments]

Usage Examples

  1. ON KEY UP
  2. ON KEY UP argument1, argument2
  3. IF condition THEN ON KEY UP

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


OPEN STATEMENT - CompilerX64 Help

OPEN STATEMENT

Open file for I/O operations

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_file_openclose.ps1
Probe status |
F1 keywords | OPEN STATEMENT, OPEN

Syntax

OPEN filespec FOR mode [ACCESS access] [LOCK lock] AS #filenum [LEN = reclen]

Usage Examples

  1. OPEN "out.txt" FOR OUTPUT AS #1
  2. OPEN "data.bin" FOR BINARY AS #2
  3. OPEN "log.txt" FOR APPEND AS #3
PRINT #3, "line"
CLOSE #3

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; runtime I/O helper call
lea     rcx, [file_descriptor]
call    cx64_file_io_helper
; status/result in rax

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


OPTION BASE - CompilerX64 Help

OPTION BASE

Default array lower bound

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | OPTION BASE, OPTION, BASE

Syntax

OPTION BASE [arguments]

Usage Examples

  1. OPTION BASE
  2. OPTION BASE argument1, argument2
  3. IF condition THEN OPTION BASE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


OR OPERATOR - CompilerX64 Help

OR OPERATOR

Bitwise and logical operator

Kind | Operator
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_expression_semantics.ps1
Probe status |
F1 keywords | OR OPERATOR, OR

Syntax

result = left_operand OR right_operand

Usage Examples

  1. OR OPERATOR
  2. OR OPERATOR argument1, argument2
  3. IF condition THEN OR OPERATOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PAINT - CompilerX64 Help

PAINT

Fill enclosed area on graphics output

Kind | Topic
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | PAINT

Syntax

PAINT [arguments]

Usage Examples

  1. PAINT
  2. PAINT argument1, argument2
  3. IF condition THEN PAINT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PARSE COMMAND LINE - CompilerX64 Help

PARSE COMMAND LINE

Parse command-line arguments

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | PARSE COMMAND LINE, PARSE, COMMAND, LINE

Syntax

PARSE COMMAND LINE [arguments]

Usage Examples

  1. PARSE COMMAND LINE
  2. PARSE COMMAND LINE argument1, argument2
  3. IF condition THEN PARSE COMMAND LINE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PASSWORD FIELD - CompilerX64 Help

PASSWORD FIELD

Edit box with masking

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | PASSWORD FIELD, PASSWORD, FIELD

Syntax

PASSWORD FIELD [arguments]

Usage Examples

  1. PASSWORD FIELD
  2. PASSWORD FIELD argument1, argument2
  3. IF condition THEN PASSWORD FIELD

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PATH NAME - CompilerX64 Help

PATH NAME

File path manipulation

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | PATH NAME, PATH, NAME

Syntax

PATH NAME [arguments]

Usage Examples

  1. PATH NAME
  2. PATH NAME argument1, argument2
  3. IF condition THEN PATH NAME

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PBWIN COMPILER - CompilerX64 Help

PBWIN COMPILER

PowerBasic Windows compiler

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | PBWIN COMPILER, PBWIN, COMPILER

Syntax

PBWIN COMPILER [arguments]

Usage Examples

  1. PBWIN COMPILER
  2. PBWIN COMPILER argument1, argument2
  3. IF condition THEN PBWIN COMPILER

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PEEK FUNCTION - CompilerX64 Help

PEEK FUNCTION

Read from memory address

Kind | Function
Lane | ASM
CX64 status | ACTIVE_BASELINE
Verification |
Probe status |
F1 keywords | PEEK FUNCTION, PEEK

Syntax

result = PEEK FUNCTION(...)

Usage Examples

  1. PEEK FUNCTION
  2. PEEK FUNCTION argument1, argument2
  3. IF condition THEN PEEK FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PERMANENT STORAGE - CompilerX64 Help

PERMANENT STORAGE

Persistent data storage

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | PERMANENT STORAGE, PERMANENT, STORAGE

Syntax

PERMANENT STORAGE [arguments]

Usage Examples

  1. PERMANENT STORAGE
  2. PERMANENT STORAGE argument1, argument2
  3. IF condition THEN PERMANENT STORAGE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PILOT Language Adapter - CompilerX64 Help

PILOT Language Adapter

PILOT language pipeline adapter

Kind | Adapter
Lane | PB-Interop
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_embedded_blocks_pcode_contract.ps1
Probe status |
F1 keywords | PILOT Language Adapter, PILOT, Language, Adapter

Syntax

PILOT Language Adapter [arguments]

Usage Examples

  1. PILOT Language Adapter
  2. PILOT Language Adapter argument1, argument2
  3. IF condition THEN PILOT Language Adapter

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PLACEHOLDER - CompilerX64 Help

PLACEHOLDER

Placeholder text/function

Kind | Function
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | PLACEHOLDER

Syntax

result = PLACEHOLDER(...)

Usage Examples

  1. PLACEHOLDER
  2. PLACEHOLDER argument1, argument2
  3. IF condition THEN PLACEHOLDER

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


POINT - CompilerX64 Help

POINT

Get mouse position

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | POINT

Syntax

POINT [arguments]

Usage Examples

  1. POINT
  2. POINT argument1, argument2
  3. IF condition THEN POINT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


POKE - CompilerX64 Help

POKE

Write to memory address

Kind | Statement
Lane | ASM
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | POKE

Syntax

POKE [arguments]

Usage Examples

  1. POKE
  2. POKE argument1, argument2
  3. IF condition THEN POKE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


POPUP MENU - CompilerX64 Help

POPUP MENU

Display context menu

Kind | Topic
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | POPUP MENU, POPUP, MENU

Syntax

POPUP MENU [arguments]

Usage Examples

  1. POPUP MENU
  2. POPUP MENU argument1, argument2
  3. IF condition THEN POPUP MENU

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


POWERSHELL EXECUTION - CompilerX64 Help

POWERSHELL EXECUTION

Run PowerShell commands

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | POWERSHELL EXECUTION, POWERSHELL, EXECUTION

Syntax

POWERSHELL EXECUTION [arguments]

Usage Examples

  1. POWERSHELL EXECUTION
  2. POWERSHELL EXECUTION argument1, argument2
  3. IF condition THEN POWERSHELL EXECUTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PRINT # - CompilerX64 Help

PRINT #

Print to file

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_iocore.ps1
Probe status |
F1 keywords | PRINT #, PRINT

Syntax

PRINT [#filenum,] expression [;|,] [expression ...]

Usage Examples

  1. PRINT "Hello from CompilerX64"
  2. PRINT Value; " items"
  3. OPEN "out.txt" FOR OUTPUT AS #1
PRINT #1, "saved"
CLOSE #1

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; console PRINT of a string literal
lea     rcx, [rel string_literal]
call    cx64_console_print_str
; integer PRINT
mov     rcx, qword ptr [rbp-8]
call    cx64_console_print_i64

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PROFILE - CompilerX64 Help

PROFILE

Performance profile

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | PROFILE

Syntax

PROFILE [arguments]

Usage Examples

  1. PROFILE
  2. PROFILE argument1, argument2
  3. IF condition THEN PROFILE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


PUT$ - CompilerX64 Help

PUT$

Put string to file

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_iocore.ps1
Probe status |
F1 keywords | PUT$

Syntax

PUT$ [arguments]

Usage Examples

  1. PUT$
  2. PUT$ argument1, argument2
  3. IF condition THEN PUT$

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


QUESTION MARK - CompilerX64 Help

QUESTION MARK

Wildcard character

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | QUESTION MARK, QUESTION, MARK

Syntax

QUESTION MARK [arguments]

Usage Examples

  1. QUESTION MARK
  2. QUESTION MARK argument1, argument2
  3. IF condition THEN QUESTION MARK

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


RANDOM ACCESS FILE - CompilerX64 Help

RANDOM ACCESS FILE

Random file I/O mode

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | RANDOM ACCESS FILE, RANDOM, ACCESS, FILE

Syntax

RANDOM ACCESS FILE [arguments]

Usage Examples

  1. RANDOM ACCESS FILE
  2. RANDOM ACCESS FILE argument1, argument2
  3. IF condition THEN RANDOM ACCESS FILE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


RANDOMIZE - CompilerX64 Help

RANDOMIZE

Seed random number generator

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | RANDOMIZE

Syntax

RANDOMIZE [arguments]

Usage Examples

  1. RANDOMIZE
  2. RANDOMIZE argument1, argument2
  3. IF condition THEN RANDOMIZE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


READ - CompilerX64 Help

READ

Read from DATA

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | READ

Syntax

READ [arguments]

Usage Examples

  1. READ
  2. READ argument1, argument2
  3. IF condition THEN READ

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


READ FROM MEMORY - CompilerX64 Help

READ FROM MEMORY

Read memory locations (alternative)

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | READ FROM MEMORY, READ, FROM, MEMORY

Syntax

READ FROM MEMORY [arguments]

Usage Examples

  1. READ FROM MEMORY
  2. READ FROM MEMORY argument1, argument2
  3. IF condition THEN READ FROM MEMORY

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


REDIM STATEMENT - CompilerX64 Help

REDIM STATEMENT

Redimension array size

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_array_redim_preserve.ps1
Probe status |
F1 keywords | REDIM STATEMENT, REDIM

Syntax

REDIM [PRESERVE] array(new_lower TO new_upper) [AS type]

Usage Examples

  1. REDIM STATEMENT
  2. REDIM STATEMENT argument1, argument2
  3. IF condition THEN REDIM STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


REGISTER KEY - CompilerX64 Help

REGISTER KEY

Registry key operations

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | REGISTER KEY, REGISTER, KEY

Syntax

REGISTER KEY [arguments]

Usage Examples

  1. REGISTER KEY
  2. REGISTER KEY argument1, argument2
  3. IF condition THEN REGISTER KEY

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


REGISTRY OPERATIONS - CompilerX64 Help

REGISTRY OPERATIONS

Windows registry access

Kind | Family
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | REGISTRY OPERATIONS, REGISTRY, OPERATIONS

Syntax

REGISTRY OPERATIONS [arguments]

Usage Examples

  1. REGISTRY OPERATIONS
  2. REGISTRY OPERATIONS argument1, argument2
  3. IF condition THEN REGISTRY OPERATIONS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


REPLACE - CompilerX64 Help

REPLACE

String replacement

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | REPLACE

Syntax

REPLACE [arguments]

Usage Examples

  1. REPLACE
  2. REPLACE argument1, argument2
  3. IF condition THEN REPLACE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


RESTORE - CompilerX64 Help

RESTORE

Reset DATA pointer

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | RESTORE

Syntax

RESTORE [arguments]

Usage Examples

  1. RESTORE
  2. RESTORE argument1, argument2
  3. IF condition THEN RESTORE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


RESUME - CompilerX64 Help

RESUME

Resume after error

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_onerror_resume_semantics.ps1
Probe status |
F1 keywords | RESUME

Syntax

RESUME [arguments]

Usage Examples

  1. RESUME
  2. RESUME argument1, argument2
  3. IF condition THEN RESUME

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


RETURN - CompilerX64 Help

RETURN

Return from subroutine/function

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_gosub_return_runtime.ps1
Probe status | PASS
F1 keywords | RETURN

Syntax

RETURN

Usage Examples

  1. RETURN
  2. RETURN argument1, argument2
  3. IF condition THEN RETURN

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


RIGHT$ FUNCTION - CompilerX64 Help

RIGHT$ FUNCTION

Extract rightmost characters

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | RIGHT$ FUNCTION, RIGHT$

Syntax

result$ = RIGHT$(string_expression, count)

Usage Examples

  1. RIGHT$ FUNCTION
  2. RIGHT$ FUNCTION argument1, argument2
  3. IF condition THEN RIGHT$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


RND FUNCTION - CompilerX64 Help

RND FUNCTION

Random number generator

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | RND FUNCTION, RND

Syntax

result = RND FUNCTION(...)

Usage Examples

  1. RND FUNCTION
  2. RND FUNCTION argument1, argument2
  3. IF condition THEN RND FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ROUND FUNCTION - CompilerX64 Help

ROUND FUNCTION

Round numeric value

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | ROUND FUNCTION, ROUND

Syntax

result = ROUND FUNCTION(...)

Usage Examples

  1. ROUND FUNCTION
  2. ROUND FUNCTION argument1, argument2
  3. IF condition THEN ROUND FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


RUN APPLICATION - CompilerX64 Help

RUN APPLICATION

Run external applications

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | RUN APPLICATION, RUN, APPLICATION

Syntax

RUN APPLICATION [arguments]

Usage Examples

  1. RUN APPLICATION
  2. RUN APPLICATION argument1, argument2
  3. IF condition THEN RUN APPLICATION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SCREEN STATEMENT - CompilerX64 Help

SCREEN STATEMENT

Set active graphics screen

Kind | Statement
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | SCREEN STATEMENT, SCREEN

Syntax

SCREEN STATEMENT [arguments]

Usage Examples

  1. SCREEN STATEMENT
  2. SCREEN STATEMENT argument1, argument2
  3. IF condition THEN SCREEN STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SEARCH IN FILES - CompilerX64 Help

SEARCH IN FILES

Recursive file search

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | SEARCH IN FILES, SEARCH, IN, FILES

Syntax

SEARCH IN FILES [arguments]

Usage Examples

  1. SEARCH IN FILES
  2. SEARCH IN FILES argument1, argument2
  3. IF condition THEN SEARCH IN FILES

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SELECT CASE - CompilerX64 Help

SELECT CASE

Multiple choice statement

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_select_case.ps1; scripts/verify_interface_task_regression.ps1
Probe status |
F1 keywords | SELECT CASE, SELECT, CASE

Syntax

SELECT CASE expression
    CASE value [, value]
        statements
    [CASE ELSE]
        statements
END SELECT

Usage Examples

  1. SELECT CASE Mode
    CASE 1
        PRINT "one"
    CASE ELSE
        PRINT "other"
END SELECT
  2. SELECT CASE Name$
    CASE "A", "B"
        PRINT "group 1"
END SELECT
  3. SELECT CASE Score
    CASE 90 TO 100
        PRINT "A"
END SELECT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; SELECT CASE numeric expression
mov     rax, [selector]
cmp     rax, 1
je      .case_1
cmp     rax, 2
je      .case_2
jmp     .case_else

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SEND MESSAGE - CompilerX64 Help

SEND MESSAGE

Send message to window/control

Kind | Topic
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | SEND MESSAGE, SEND, MESSAGE

Syntax

SEND MESSAGE [arguments]

Usage Examples

  1. SEND MESSAGE
  2. SEND MESSAGE argument1, argument2
  3. IF condition THEN SEND MESSAGE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SET FOCUS - CompilerX64 Help

SET FOCUS

Give keyboard focus (alternative)

Kind | Topic
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | SET FOCUS, SET, FOCUS

Syntax

SET FOCUS [arguments]

Usage Examples

  1. SET FOCUS
  2. SET FOCUS argument1, argument2
  3. IF condition THEN SET FOCUS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SET FONT - CompilerX64 Help

SET FONT

Change font (alternative)

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | SET FONT, SET, FONT

Syntax

SET FONT [arguments]

Usage Examples

  1. SET FONT
  2. SET FONT argument1, argument2
  3. IF condition THEN SET FONT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SETATTR - CompilerX64 Help

SETATTR

Set file attributes

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | SETATTR

Syntax

SETATTR [arguments]

Usage Examples

  1. SETATTR
  2. SETATTR argument1, argument2
  3. IF condition THEN SETATTR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SETEOF - CompilerX64 Help

SETEOF

Set end of file

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_file_openclose.ps1
Probe status |
F1 keywords | SETEOF

Syntax

SETEOF [arguments]

Usage Examples

  1. SETEOF
  2. SETEOF argument1, argument2
  3. IF condition THEN SETEOF

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SHELL STATEMENT - CompilerX64 Help

SHELL STATEMENT

Run external program

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | SHELL STATEMENT, SHELL

Syntax

SHELL command_line [, style]

Usage Examples

  1. SHELL STATEMENT
  2. SHELL STATEMENT argument1, argument2
  3. IF condition THEN SHELL STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SHOW WINDOW - CompilerX64 Help

SHOW WINDOW

Show window state

Kind | Topic
Lane | PB-UI
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | SHOW WINDOW, SHOW, WINDOW

Syntax

SHOW WINDOW [arguments]

Usage Examples

  1. SHOW WINDOW
  2. SHOW WINDOW argument1, argument2
  3. IF condition THEN SHOW WINDOW

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SLEEP - CompilerX64 Help

SLEEP

Pause execution

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | SLEEP

Syntax

SLEEP [arguments]

Usage Examples

  1. SLEEP
  2. SLEEP argument1, argument2
  3. IF condition THEN SLEEP

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


STATIC - CompilerX64 Help

STATIC

Static variable declaration

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status | COMPILE_FAIL
F1 keywords | STATIC

Syntax

STATIC [arguments]

Usage Examples

  1. STATIC
  2. STATIC argument1, argument2
  3. IF condition THEN STATIC

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


STRING OPERATIONS - CompilerX64 Help

STRING OPERATIONS

String manipulation functions

Kind | Family
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | STRING OPERATIONS, STRING, OPERATIONS

Syntax

STRING OPERATIONS [arguments]

Usage Examples

  1. STRING OPERATIONS
  2. STRING OPERATIONS argument1, argument2
  3. IF condition THEN STRING OPERATIONS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SUB FUNCTION METHOD PROPERTY - CompilerX64 Help

SUB FUNCTION METHOD PROPERTY

Object members

Kind | Function
Lane | PB-Objects
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | SUB FUNCTION METHOD PROPERTY, SUB, FUNCTION, METHOD, PROPERTY

Syntax

SUB name(parameters)
    statements
END SUB

FUNCTION name(parameters) AS type
    statements
END FUNCTION

Usage Examples

  1. SUB Main()
    PRINT "main"
END SUB
  2. FUNCTION Add(BYVAL A AS LONG, BYVAL B AS LONG) AS LONG
    FUNCTION = A + B
END FUNCTION
  3. CALL Main()

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SUBTRACT OPERATOR - CompilerX64 Help

SUBTRACT OPERATOR

Arithmetic subtraction

Kind | Operator
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_expression_semantics.ps1
Probe status |
F1 keywords | SUBTRACT OPERATOR, SUBTRACT

Syntax

result = left_operand SUBTRACT right_operand

Usage Examples

  1. SUBTRACT OPERATOR
  2. SUBTRACT OPERATOR argument1, argument2
  3. IF condition THEN SUBTRACT OPERATOR

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


SUM ARRAY - CompilerX64 Help

SUM ARRAY

Sum array elements (PowerArray)

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | SUM ARRAY, SUM, ARRAY

Syntax

SUM ARRAY [arguments]

Usage Examples

  1. SUM ARRAY
  2. SUM ARRAY argument1, argument2
  3. IF condition THEN SUM ARRAY

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


THINPRINT - CompilerX64 Help

THINPRINT

Thin client print

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | THINPRINT

Syntax

THINPRINT [arguments]

Usage Examples

  1. THINPRINT
  2. THINPRINT argument1, argument2
  3. IF condition THEN THINPRINT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


TRACE - CompilerX64 Help

TRACE

Debug trace

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | TRACE

Syntax

TRACE [arguments]

Usage Examples

  1. TRACE
  2. TRACE argument1, argument2
  3. IF condition THEN TRACE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


TRY / CATCH / FINALLY - CompilerX64 Help

TRY / CATCH / FINALLY

Structured exception handling

Kind | Statement
Lane | PB-ControlFlow
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | TRY / CATCH / FINALLY, TRY, CATCH, FINALLY

Syntax

TRY / CATCH / FINALLY [arguments]

Usage Examples

  1. TRY / CATCH / FINALLY
  2. TRY / CATCH / FINALLY argument1, argument2
  3. IF condition THEN TRY / CATCH / FINALLY

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


UCASE$ FUNCTION - CompilerX64 Help

UCASE$ FUNCTION

Convert to uppercase

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | UCASE$ FUNCTION, UCASE$

Syntax

result = UCASE$ FUNCTION(...)

Usage Examples

  1. UCASE$ FUNCTION
  2. UCASE$ FUNCTION argument1, argument2
  3. IF condition THEN UCASE$ FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


UNION - CompilerX64 Help

UNION

Union definition

Kind | Datatype
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_udt_layout64.ps1
Probe status |
F1 keywords | UNION

Syntax

UNION [arguments]

Usage Examples

  1. UNION
  2. UNION argument1, argument2
  3. IF condition THEN UNION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


UNLOAD MODULE - CompilerX64 Help

UNLOAD MODULE

Unload external module

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | UNLOAD MODULE, UNLOAD, MODULE

Syntax

UNLOAD MODULE [arguments]

Usage Examples

  1. UNLOAD MODULE
  2. UNLOAD MODULE argument1, argument2
  3. IF condition THEN UNLOAD MODULE

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


UNLOCK - CompilerX64 Help

UNLOCK

Unlock file region

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_file_openclose.ps1
Probe status |
F1 keywords | UNLOCK

Syntax

UNLOCK [arguments]

Usage Examples

  1. UNLOCK
  2. UNLOCK argument1, argument2
  3. IF condition THEN UNLOCK

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


UPDATE RECORD - CompilerX64 Help

UPDATE RECORD

Update random access record

Kind | Topic
Lane | PB-RuntimeIO
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | UPDATE RECORD, UPDATE, RECORD

Syntax

UPDATE RECORD [arguments]

Usage Examples

  1. UPDATE RECORD
  2. UPDATE RECORD argument1, argument2
  3. IF condition THEN UPDATE RECORD

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


VAL FUNCTION - CompilerX64 Help

VAL FUNCTION

Convert string to number

Kind | Function
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | VAL FUNCTION, VAL

Syntax

result = VAL(string_expression)

Usage Examples

  1. VAL FUNCTION
  2. VAL FUNCTION argument1, argument2
  3. IF condition THEN VAL FUNCTION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


VARIABLES - CompilerX64 Help

VARIABLES

Variable declaration and usage

Kind | Family
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | VARIABLES

Syntax

VARIABLES [arguments]

Usage Examples

  1. VARIABLES
  2. VARIABLES argument1, argument2
  3. IF condition THEN VARIABLES

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


VERSION INFORMATION - CompilerX64 Help

VERSION INFORMATION

Application version data

Kind | Topic
Lane | HELP
CX64 status | EXCLUDED_NONCOMPILER
Verification |
Probe status |
F1 keywords | VERSION INFORMATION, VERSION, INFORMATION

Syntax

VERSION INFORMATION [arguments]

Usage Examples

  1. VERSION INFORMATION
  2. VERSION INFORMATION argument1, argument2
  3. IF condition THEN VERSION INFORMATION

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: EXCLUDED_NONCOMPILER
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


WIDTH - CompilerX64 Help

WIDTH

Console/file width

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | WIDTH

Syntax

WIDTH [arguments]

Usage Examples

  1. WIDTH
  2. WIDTH argument1, argument2
  3. IF condition THEN WIDTH

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


WITH - CompilerX64 Help

WITH

UDT context block

Kind | Statement
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_e2e_core.ps1
Probe status |
F1 keywords | WITH

Syntax

WITH [arguments]

Usage Examples

  1. WITH
  2. WITH argument1, argument2
  3. IF condition THEN WITH

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


WRITE # - CompilerX64 Help

WRITE #

Write to file

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_iocore.ps1
Probe status |
F1 keywords | WRITE #, WRITE

Syntax

WRITE # [arguments]

Usage Examples

  1. WRITE #
  2. WRITE # argument1, argument2
  3. IF condition THEN WRITE #

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


WRITE # STATEMENT - CompilerX64 Help

WRITE # STATEMENT

Write formatted data to file

Kind | Statement
Lane | PB-RuntimeIO
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_iocore.ps1
Probe status |
F1 keywords | WRITE # STATEMENT, WRITE #, WRITE

Syntax

WRITE # STATEMENT [arguments]

Usage Examples

  1. WRITE # STATEMENT
  2. WRITE # STATEMENT argument1, argument2
  3. IF condition THEN WRITE # STATEMENT

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; runtime I/O helper call
lea     rcx, [file_descriptor]
call    cx64_file_io_helper
; status/result in rax

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


WRITE TO MEMORY - CompilerX64 Help

WRITE TO MEMORY

Write memory locations (alternative)

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | PLANNED
Verification |
Probe status |
F1 keywords | WRITE TO MEMORY, WRITE, TO, MEMORY

Syntax

WRITE TO MEMORY [arguments]

Usage Examples

  1. WRITE TO MEMORY
  2. WRITE TO MEMORY argument1, argument2
  3. IF condition THEN WRITE TO MEMORY

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; No verified CompilerX64 assembly lowering is recorded for this topic yet.
; Status in PB_COMMAND_MATRIX.md: PLANNED
; Keep this section as a task marker until a focused proof captures generated code.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.


ZERO BASED ARRAYS - CompilerX64 Help

ZERO BASED ARRAYS

Zero-indexed array access

Kind | Topic
Lane | PB-TypesStringsArrays
CX64 status | ACTIVE_BASELINE
Verification | scripts/verify_runtime_arraycore.ps1
Probe status |
F1 keywords | ZERO BASED ARRAYS, ZERO, BASED, ARRAYS

Syntax

ZERO BASED ARRAYS [arguments]

Usage Examples

  1. ZERO BASED ARRAYS
  2. ZERO BASED ARRAYS argument1, argument2
  3. IF condition THEN ZERO BASED ARRAYS

CompilerX64 Technical Notes

This section records how CompilerX64 currently treats this command family. For active baseline rows, the assembly is the intended lowering shape used by the current x64 backend/runtime path; planned rows stay explicit until a focused proof records exact output.

Generated Assembly / Lowering

; Active baseline topic. Capture exact emitted assembly from a focused -ASMOUT proof before replacing this overview.
; Typical shape: evaluate operands into Windows x64 registers, call runtime/helper or emit branch/arithmetic instructions, store result.

Compatibility Notes

Syntax is modeled after PowerBASIC-style usage, but this page documents CompilerX64 behavior and support status. Prefer the listed verification script when changing this command.